Pro 575 Temperature Issues

wdyer

New member
Joined
May 6, 2019
Messages
3
Reaction score
1
Points
3
Hello, we purchased the Pro 575 last week, followed all instructions for installation and seasoning and were anxious to try it, we wanted to follow specific Traeger recipes as we are new to pellet grilling. Saturday we did the 70 Minute Chicken Challenge and Sunday we did the Bloody Mary Flank Steak. We had a couple of sides for the chicken that were cooked at the same temp (375), we opened the grill a couple times, we thought the heat really dropped quickly and maybe we hadn't been quick enough adding the sides and kept the lid open too long. Anyway, the chicken took forever to cook, I mean forever, 2 1/2 hours! The skin never got crunchy but once it was done, the chicken was delicious, we used our own meat probe to determine when it was done, because something just didn't seem right and maybe us newbies didn't do something correct.
Yesterday was the flank steak with the grill set to (450), we followed all instructions to preheat and we were ready to try again, it was supposed to be cooked 7-10 minutes on each side and when we went to flip it, it didn't look ready to flip, bottom line, steak also took twice as long to cook then instructed. Once we got it to the proper cook temp of 135, it was again delicious but didn't have a sear/crunch.

Today we bought an Analog Instant Read Oven Thermometer and tested the display temps vs. thermometer, following all preheating instructions.
Set at 275 / Display Showed 271 / Thermometer 218
Set at 375 / Display Showed 370 / Thermometer 293
Set at 450 / Display Showed 455 / Thermometer 348

Now we know, I saw a few threads regarding this issue, anyone at customer service have an answer for those dealing with this same issue ?
 

TXFIre

Member
Joined
Apr 20, 2019
Messages
36
Reaction score
11
Points
8
Grill
Ironwood 650
Same here too.Waiting on a replacement thermocouple and D2 controller.
 

Biffdotorg

Member
Joined
May 1, 2019
Messages
62
Reaction score
21
Points
8
Location
Dilworth, MN
Grill
Pro 780
Did you notice any difference in accuracy after doing a temp probe calibration? There are instruction in the manual. I have yet to do this, so I am asking out of curiosity to see if it helped.

Good luck,
 

Sokiey

New member
Joined
May 7, 2019
Messages
4
Reaction score
1
Points
3
I'm getting the same problem here in the UK, things taking ages to cook set to 450 other probe is reading 350 right next to it :-(
 

Blood-root

New member
Joined
May 26, 2019
Messages
11
Reaction score
2
Points
3
Location
Ny
Grill
Pro 575
Same problem here.. called traeger and there sending a RTD. I told them it’s the controller so when this RTD doesn’t Ewok they will send a controller.. I’m with dave1972. To me sesames like a software problem. I got the update software bit that hasn’t changed anything. So they can send me a new controller so I’ll have two. But they probably will both have the same software.

I’ll keep sending them emails. But if you want a response call. That what the tech advised.
 

Jeremy

New member
Joined
May 23, 2019
Messages
1
Reaction score
0
Points
1
Location
Buffalo
Grill
Traeger Pro 575
Mine is sitting at the same temp points too. Supposedly have a new "temp kit" on the way. They won't call it a RTD probe. Unsure if I should return whole grill or let Traeger figure this out.
 

Niw

New member
Joined
May 30, 2019
Messages
4
Reaction score
0
Points
1
Location
Denmark
Grill
Pro575
Hello, we purchased the Pro 575 last week, followed all instructions for installation and seasoning and were anxious to try it, we wanted to follow specific Traeger recipes as we are new to pellet grilling. Saturday we did the 70 Minute Chicken Challenge and Sunday we did the Bloody Mary Flank Steak. We had a couple of sides for the chicken that were cooked at the same temp (375), we opened the grill a couple times, we thought the heat really dropped quickly and maybe we hadn't been quick enough adding the sides and kept the lid open too long. Anyway, the chicken took forever to cook, I mean forever, 2 1/2 hours! The skin never got crunchy but once it was done, the chicken was delicious, we used our own meat probe to determine when it was done, because something just didn't seem right and maybe us newbies didn't do something correct.
Yesterday was the flank steak with the grill set to (450), we followed all instructions to preheat and we were ready to try again, it was supposed to be cooked 7-10 minutes on each side and when we went to flip it, it didn't look ready to flip, bottom line, steak also took twice as long to cook then instructed. Once we got it to the proper cook temp of 135, it was again delicious but didn't have a sear/crunch.

Today we bought an Analog Instant Read Oven Thermometer and tested the display temps vs. thermometer, following all preheating instructions.
Set at 275 / Display Showed 271 / Thermometer 218
Set at 375 / Display Showed 370 / Thermometer 293
Set at 450 / Display Showed 455 / Thermometer 348

Now we know, I saw a few threads regarding this issue, anyone at customer service have an answer for those dealing with this same issue ?
I have the same problem with my
Hello, we purchased the Pro 575 last week, followed all instructions for installation and seasoning and were anxious to try it, we wanted to follow specific Traeger recipes as we are new to pellet grilling. Saturday we did the 70 Minute Chicken Challenge and Sunday we did the Bloody Mary Flank Steak. We had a couple of sides for the chicken that were cooked at the same temp (375), we opened the grill a couple times, we thought the heat really dropped quickly and maybe we hadn't been quick enough adding the sides and kept the lid open too long. Anyway, the chicken took forever to cook, I mean forever, 2 1/2 hours! The skin never got crunchy but once it was done, the chicken was delicious, we used our own meat probe to determine when it was done, because something just didn't seem right and maybe us newbies didn't do something correct.
Yesterday was the flank steak with the grill set to (450), we followed all instructions to preheat and we were ready to try again, it was supposed to be cooked 7-10 minutes on each side and when we went to flip it, it didn't look ready to flip, bottom line, steak also took twice as long to cook then instructed. Once we got it to the proper cook temp of 135, it was again delicious but didn't have a sear/crunch.

Today we bought an Analog Instant Read Oven Thermometer and tested the display temps vs. thermometer, following all preheating instructions.
Set at 275 / Display Showed 271 / Thermometer 218
Set at 375 / Display Showed 370 / Thermometer 293
Set at 450 / Display Showed 455 / Thermometer 348

Now we know, I saw a few threads regarding this issue, anyon
Hello, we purchased the Pro 575 last week, followed all instructions for installation and seasoning and were anxious to try it, we wanted to follow specific Traeger recipes as we are new to pellet grilling. Saturday we did the 70 Minute Chicken Challenge and Sunday we did the Bloody Mary Flank Steak. We had a couple of sides for the chicken that were cooked at the same temp (375), we opened the grill a couple times, we thought the heat really dropped quickly and maybe we hadn't been quick enough adding the sides and kept the lid open too long. Anyway, the chicken took forever to cook, I mean forever, 2 1/2 hours! The skin never got crunchy but once it was done, the chicken was delicious, we used our own meat probe to determine when it was done, because something just didn't seem right and maybe us newbies didn't do something correct.
Yesterday was the flank steak with the grill set to (450), we followed all instructions to preheat and we were ready to try again, it was supposed to be cooked 7-10 minutes on each side and when we went to flip it, it didn't look ready to flip, bottom line, steak also took twice as long to cook then instructed. Once we got it to the proper cook temp of 135, it was again delicious but didn't have a sear/crunch.

Today we bought an Analog Instant Read Oven Thermometer and tested the display temps vs. thermometer, following all preheating instructions.
Set at 275 / Display Showed 271 / Thermometer 218
Set at 375 / Display Showed 370 / Thermometer 293
Set at 450 / Display Showed 455 / Thermometer 348

Now we know, I saw a few threads regarding this issue, anyone at customer service have an answer for those dealing with this same issue ?
I have the same problem with my 575 (Temp on picture in Celsius)
 

Attachments

Last edited:

JordanK

Active member
Joined
May 7, 2019
Messages
108
Reaction score
41
Points
28
I have the same problem with my



I have the same problem with my 575 Temp on picture in Celsius)
Have you updated the firmware to Version 01.01.01 Config 04.010? The update fixed issues at the low temperature range. My Pro 575 holds 225F really well.
 

dehle

New member
Joined
May 29, 2019
Messages
17
Reaction score
3
Points
3
Location
victoria bc canada
Grill
pro 575
I've had a 575 for a little over a week, firmware 01.01.01. Seeing similar to other posters - actual temperature is approximately 30% lower than unit's display temperature. High setting (450) only gets to approx. 350.
 

mikefox10

New member
Joined
Jun 4, 2019
Messages
1
Reaction score
0
Points
1
Location
Minnesota
Grill
Pro 575
Same problem with my Pro 575. I've got the latest firmware but temp was off on avg 60 degrees and it would not get over about 350, I just returned it and bought a Rec Tec Stampede.
 

KirkP

Member
Joined
Apr 29, 2019
Messages
97
Reaction score
17
Points
8
Location
Moscow, ID
Grill
Pro 575
Same problem with my Pro 575. I've got the latest firmware but temp was off on avg 60 degrees and it would not get over about 350, I just returned it and bought a Rec Tec Stampede.
Did the same a couple of weeks ago. Absolutely loving my RecTec.
 

primeone

Administrator
Staff member
Joined
Feb 12, 2019
Messages
489
Reaction score
107
Points
43
Location
Austin, TX
Grill
Ironwood 650
Yes, getting to be a bit of a group. For the record I still like my old BBQ-124 model
Maybe someone from Traeger will run across this thread and it will lite a fire under the engineers to finally resolve these new Pro issues.
 
Top