Says preheat is done early....

John S.

Active member
Joined
Jul 12, 2020
Messages
289
Reaction score
106
Points
43
Location
San Mateo Ca.
Grill
Timberline 1300
I start up my 1300 at 165 and then when it gets going about 140, I set it to the desired temp in this case 410 to start... however the 1300 says preheat complete at 250 , shouldn’t it wait until the set point is reached to send out this response ?
 

Timmy

Well-known member
Joined
Jul 5, 2020
Messages
887
Reaction score
435
Points
63
Location
Iowa
Grill
Pro 780, Bronson 20 , Char grill gasser, Char griller modified offset, Blackstone 3 burner griddle
I would think so. But it may have the 165 in memory. No sure, just a guess.
 

RemE

Moderator
Staff member
Joined
Jun 10, 2019
Messages
1,259
Reaction score
733
Points
113
Location
Corona Del Mar, California
Grill
Timberline 850
Probably confused it. With the latest firmware I set to desired temp and go.
 

Jacob_Sausalito

New member
Joined
Mar 27, 2020
Messages
10
Reaction score
7
Points
3
Location
Sausalito, CA
Grill
Pro 575
I agree, I don't think there's any need to first set it to 165 and then to 410 after it's warmed up. Just set it to 410 from the start.
 
OP
OP
John S.

John S.

Active member
Joined
Jul 12, 2020
Messages
289
Reaction score
106
Points
43
Location
San Mateo Ca.
Grill
Timberline 1300
This is the software set that I am using. I believe that it is current. Any idea when the next update is expected....
 

Attachments

  • 7858BF14-C96B-41E4-9E4C-DEBD460AF58D.png
    7858BF14-C96B-41E4-9E4C-DEBD460AF58D.png
    1,017.8 KB · Views: 12

RemE

Moderator
Staff member
Joined
Jun 10, 2019
Messages
1,259
Reaction score
733
Points
113
Location
Corona Del Mar, California
Grill
Timberline 850
This is the software set that I am using. I believe that it is current. Any idea when the next update is expected....
That's current firmware, you should be able to just set your desired temp and hit ignite. Grill should steadily climb to the set temp. It may say ready just before hitting temp but no biggie.
 

Chad

New member
Joined
May 9, 2020
Messages
3
Reaction score
0
Points
1
Location
Alabama
Grill
Ironwood 885
I start up my 1300 at 165 and then when it gets going about 140, I set it to the desired temp in this case 410 to start... however the 1300 says preheat complete at 250 , shouldn’t it wait until the set point is reached to send out this response ?
My ironwood 885 stops preheating early every single time I use it now. I set it to 500 and it stops at 350. Maybe someone else knows the problem.
 

Chad

New member
Joined
May 9, 2020
Messages
3
Reaction score
0
Points
1
Location
Alabama
Grill
Ironwood 885
I start up my 1300 at 165 and then when it gets going about 140, I set it to the desired temp in this case 410 to start... however the 1300 says preheat complete at 250 , shouldn’t it wait until the set point is reached to send out this response ?
I have to burp the lid several times to drop the temp in order for it to start back trying to get up
 

RemE

Moderator
Staff member
Joined
Jun 10, 2019
Messages
1,259
Reaction score
733
Points
113
Location
Corona Del Mar, California
Grill
Timberline 850
It's a feedback driven system, it reads the pit temp and varies the pellet feed to attain and maintain the set temp. Regardless of weather you open the lid, the controller will adjust the feed to get the set temp. It would be interesting to see a temp plot from something like a Fireboard thermometer to document what your particular grill does.
 

Chad

New member
Joined
May 9, 2020
Messages
3
Reaction score
0
Points
1
Location
Alabama
Grill
Ironwood 885
It's a feedback driven system, it reads the pit temp and varies the pellet feed to attain and maintain the set temp. Regardless of weather you open the lid, the controller will adjust the feed to get the set temp. It would be interesting to see a temp plot from something like a Fireboard thermometer to document what your particular grill does.
My problem is it just stops preheating period. I set it to 500 and it stops preheating at 350. It will stay at 350 until I burp it and then it might go to 400. Rinse repeat a couple times. Finally will get close to 500. I have the set temp at 500 the whole time
 

RemE

Moderator
Staff member
Joined
Jun 10, 2019
Messages
1,259
Reaction score
733
Points
113
Location
Corona Del Mar, California
Grill
Timberline 850
My problem is it just stops preheating period. I set it to 500 and it stops preheating at 350. It will stay at 350 until I burp it and then it might go to 400. Rinse repeat a couple times. Finally will get close to 500. I have the set temp at 500 the whole time
I hear what you are saying, but digital controllers don't just stop controlling. If you let it sit, it will climb to 500 by itself. I'd do a test run and time it. If it doesn't go to 500 by itself, I'd call service and get a new controller.
 

Latest Discussions

Top