🌟 Exclusive 2024 Prime Day Deals! 🌟

Unlock unbeatable offers today. Shop here: https://amzn.to/4cZ6eck 🎁

Probe off mid cook.

Jmthornt

Member
Joined
Apr 21, 2020
Messages
32
Reaction score
22
Points
8
Location
Texas
Grill
Pro 575
So an odd thing happened today, if this is covered somewhere else, please forgive. But wondering if others have experienced. I have a Pro 575. Had for over a month, no problems. Took the firmware update yesterday, not that I think this is related. Cooking a brisket today, about two hours into the cook, I pull the meat probe out to readjust, temp dropped 40 degrees. And never recovered. The remainder of the cook, it consistently rose, but a good 40 degrees off. I have a secondary blue-tooth probe and a therma-pen. Not overly concerned, I’ll recalibrate tomorrow or Monday and see if better. Just odd. Before today it’s been very accurate. The chamber temp monitor, and performance of everything else was spot on. Just the internal meat probe registering low.
 
I gave up on the integrated meat probe after I found it inaccurate and constantly had to recalibrate. Sometimes it was accurate but I won’t even chance it to mess up a cook and just use either my iGrill2 or Fireboard.
 
I gave up on the integrated meat probe after I found it inaccurate and constantly had to recalibrate. Sometimes it was accurate but I won’t even chance it to mess up a cook and just use either my iGrill2 or Fireboard.
Well I never calibrated with the ice bath. I compared to my own pen and it was off 3 degrees. Have been cooking with that. The 30-40 degree drop and remaining off during the cook was a little disconcerting. I calibrated this morning with the ice bath. Will see how that works. My instant pen is the end all when it comes to internal temps, but if a $20 pen can stay accurate, the Traeger should. May try it again today or tomorrow. Thanks.
 
Back
Top