Pro 575 not getting above 400

Bbqeh!

New member
Joined
Oct 30, 2019
Messages
9
Reaction score
0
Points
1
Location
Canada
Grill
Pro 575 D2
Hey all.
just found this forum and I just got my unit, pro 575 D2. It has been updated to .04 FW. Temps are pretty dang close to the read out, within 6 degrees until about 350 and above. Then the spread seems to be about 6-8 degrees for me.
I can’t tell what it is at 400 because my unit won’t get to 400 on the display. After almost 1.5 hours the best I could get was 390 displayed temp and 399 measured temp on 450 setting.
called CS. They are telling me it’s my fan. It should never stop. I thought it was a variable speed fan?
Anyone else see this?
I am thinking controller but what do I know. I am not reading a script at a CS job.
 
Last edited:
Joined
Aug 29, 2019
Messages
53
Reaction score
7
Points
8
Location
PA
Grill
Pro 575
Once mine is running the fan never stops. Your in CN, how cold is it up there? When it gets cool here I put a blanket on mine but I'm not going to 400. If your fan stops running you do have an issue but do you really need the thing to get to 400 +? If you do I'd put a welder's blanket on it.
 
  • Thread Starter Thread Starter
  • #3

Bbqeh!

New member
Joined
Oct 30, 2019
Messages
9
Reaction score
0
Points
1
Location
Canada
Grill
Pro 575 D2
Yes in SW Ontario. Last night it was 40F. Can get to -20F or colder in winter. I have a blanket on it.
Fan cycles up or down but yes never stops.
unless you leave the lid open for a while. It seems the fan goes high then in very low speed because it’s loosing temp fast when you have the lid open for say 4 minutes.

I use the high temps for crisping up Usually or just cooking fast like a grill when needed.
I did end up calling Traeger CANADA tech guy was super helpful. Hands down knows their stuff better than the CS in the Utah centre.
he thinks it’s a faulty RTD probe and sending me a new one. Gonna try that and see. If that’s not it it could be the controller but unlikely because it performs well otherwise.
 
Joined
Aug 29, 2019
Messages
53
Reaction score
7
Points
8
Location
PA
Grill
Pro 575
They apparently give those probes out like water. If you take the top screws off of your hopper box and tilt it back as far as the bottom ones will let you and tape a long piece of thread to the old probe you can use the thread to pull the new probe into place. You'll also want a long, thin screwdriver to help nudge it in from the back. Otherwise you'll need to take a bunch of stuff off to install it. Mine made no difference and now they're sending me a controller. Actually, a second controller, the first one they sent was defective.
 
  • Thread Starter Thread Starter
  • #5

Bbqeh!

New member
Joined
Oct 30, 2019
Messages
9
Reaction score
0
Points
1
Location
Canada
Grill
Pro 575 D2
They apparently give those probes out like water. If you take the top screws off of your hopper box and tilt it back as far as the bottom ones will let you and tape a long piece of thread to the old probe you can use the thread to pull the new probe into place. You'll also want a long, thin screwdriver to help nudge it in from the back. Otherwise you'll need to take a bunch of stuff off to install it. Mine made no difference and now they're sending me a controller. Actually, a second controller, the first one they sent was defective.
any luck with the 2nd controller?
 
  • Thread Starter Thread Starter
  • #7

Bbqeh!

New member
Joined
Oct 30, 2019
Messages
9
Reaction score
0
Points
1
Location
Canada
Grill
Pro 575 D2
The first one they sent was defective, I couldn't plug the probe connector into it and the next one is on backorder.
Dang. Well goes to show if they are on back order. They are going through too many. Well hope they get one out to you soon. You dealing with the US support or CANADA support in Barrie ?
 
Joined
Aug 29, 2019
Messages
53
Reaction score
7
Points
8
Location
PA
Grill
Pro 575
Dang. Well goes to show if they are on back order. They are going through too many. Well hope they get one out to you soon. You dealing with the US support or CANADA support in Barrie ?
US, I think they're in Utah. I do give them credit for being accessible and having people there who I can understand when I talk to them on the phone. I just find it unfortunate that I have this problem. The only saving grave I have is that my discrepancy is a consistent 20 degrees and I am able to compensate for it.
 
  • Thread Starter Thread Starter
  • #9

Bbqeh!

New member
Joined
Oct 30, 2019
Messages
9
Reaction score
0
Points
1
Location
Canada
Grill
Pro 575 D2
I could deal with that as well but I can’t even get above 400. That’s my beef. I just got a new fan and a new rtd probe that arrived. Going to swap those and cross my fingers.
 

MRQ

New member
Joined
Oct 14, 2019
Messages
1
Reaction score
0
Points
1
Location
California
Grill
Traeger Junior
I don't have your issues on my Jr. I've had much more consistent results since I put firebricks around burner to increase the thermal mass.
Having something to hold the heat might help you increase it. I bought mine at Ace Hardware, but I may get more at the local ceramic store.
 
  • Thread Starter Thread Starter
  • #11

Bbqeh!

New member
Joined
Oct 30, 2019
Messages
9
Reaction score
0
Points
1
Location
Canada
Grill
Pro 575 D2
Well I actually figured it out.
between old pellets and access dust from those pellets. It was not burning clean.
I emptied the hopper vacuumed it out completely and fresh new pellets.
thing shot straight up to 460.
these new units sure need to be clean.
something my tailgater sure is less finicky on.
Who knew
 
Top