New - Traeger D2 Firmware V01.01.02

primeone

Administrator
Staff member
Joined
Feb 12, 2019
Messages
1,306
Reaction score
782
Points
113
Location
Austin, TX
Grill
2023 Ironwood-L
I thought it might be helpful to start a new thread for those who have the new v01.01.02 firmware update. Please let us know if the new update fixes some of the past temp issues, temp swings, etc. So far it looks like most of the reviews have been positive!
 
I thought it might be helpful to start a new thread for those who have the new v01.01.02 firmware update. Please let us know if the new update fixes some of the past temp issues, temp swings, etc. So far it looks like most of the reviews have been positive!
 
My update has worked great. High temps are pretty accurate, maybe within 5 degrees. Lower temps a little more, 5-15 I’d say. I set 235 for a 225 cook and internal probe held around 220.
 
I grilled steaks last night on my Pro 575. Set the grill to 400F and my oven thermometer was within 5 degrees. So far the new firmer is awesome. The only thing I have noticed is that it heats up very quick until about 75% of the set temperature but the last 25% seems to take longer. As an example, I set it to 400F last night. It heated nicely to about 360F but then it seemed to take extra time to go from 360F to 400F. Might just be my imagination or they might have built something in to prevent overshooting the set point. In any case, I’m extremely happy,
 
Tried the update on the fourth. My 575 was off 50 degrees before the update, now it is within 10. Interesting that the update fixed a problem customer support said did not exist.
 
This update also fixed myb ssue with the meat temp probe. It was off 23 degrees before and now it's dead on.
 
My Ironwood 885 ac wifire got updated to v.2.0.0.3, there's no info on traegers pages about it(yet). Anyone noticed any improvements?
 
Tried the update on the fourth. My 575 was off 50 degrees before the update, now it is within 10. Interesting that the update fixed a problem customer support said did not exist.


Hope this solves mine too, fired it up before I saw this so shutting down now to do the update.
 
I just found out that my 575 has downloaded the 01.01.02 software, so I fired it up with my Fluke temp probe next to the grills own probe, and it seems that they have solved the temp problem
 
Mine is much better after 02 version downloaded.
 
Ironwood 650 at 225 on controller 236 internal then at 500 on controller 511 internal. 350 was dead on at 350, temps held great overtime as well.
 
Updated today. I’m keeping my fingers crossed. I’ve been waiting since Memorial Day for a new RTD.
 
My update has worked great. High temps are pretty accurate, maybe within 5 degrees. Lower temps a little more, 5-15 I’d say. I set 235 for a 225 cook and internal probe held around 220.
I have my ironwood 885 plugged in now, waiting for the update? Is there anything I need to do to force the update?
 
I have my ironwood 885 plugged in now, waiting for the update? Is there anything I need to do to force the update?
No. Just plug it in, turn it on and make sure its connected to Wifi with a good signal. Should update within 10-15 minutes.
 
No. Just plug it in, turn it on and make sure its connected to Wifi with a good signal. Should update within 10-15 minutes.
Thanks. Just updated. Hopefully the low temp issues will be good to go now.
 
Back
Top