New Pro 570 issues

Bigblue09

New member
Joined
Apr 20, 2020
Messages
7
Reaction score
0
Points
1
Location
Georgia
Grill
Pro 570
Hello, I just purchased my first Traeger which is a Pro 570. I am having an issue with it connecting. When I first started it up and tried to connect it to the wifi it said it was connected and it was doing an update. Now it is stuck on downloading files. It says its connected to my network but it is still downloading files. It has been on and stuck on that for 2 full days now. It won't connect to my phone I'm assuming because it is still working on the update or something. The grill works fine but I'm getting frustrated with the wifi part. I've tried unplugging it and it still says that under wifi information. Any suggestions?
 

denmyos

New member
Joined
Apr 7, 2020
Messages
27
Reaction score
3
Points
3
Location
europe
Grill
pro 575
Which phone do you have..
What version of the app are you on?
 
OP
OP
B

Bigblue09

New member
Joined
Apr 20, 2020
Messages
7
Reaction score
0
Points
1
Location
Georgia
Grill
Pro 570
No. It always says unable to connect to grill. I tried the reset where you hold the ignite button while in the about menu but it didn't really reset anything. It just turned off and when I turned it back on nothing changed.
 
OP
OP
B

Bigblue09

New member
Joined
Apr 20, 2020
Messages
7
Reaction score
0
Points
1
Location
Georgia
Grill
Pro 570
This is what its been stuck on for 2 days now.
 

Attachments

  • 20200420_143921.jpg
    20200420_143921.jpg
    211.3 KB · Views: 50

denmyos

New member
Joined
Apr 7, 2020
Messages
27
Reaction score
3
Points
3
Location
europe
Grill
pro 575
I would try to shut of the grill, and wait a few minutes, and then starte it again.
And see what happens.
 
OP
OP
B

Bigblue09

New member
Joined
Apr 20, 2020
Messages
7
Reaction score
0
Points
1
Location
Georgia
Grill
Pro 570
I unplugged it and let it sit for about 30 minutes and it still says the same thing.
 

MikeyR

Active member
Joined
Feb 23, 2020
Messages
210
Reaction score
52
Points
28
Location
Calgary
Grill
Ironwood 650
Try putting it in sales demo mode, last options in settings menu.

Or try this:
 
Last edited:
OP
OP
B

Bigblue09

New member
Joined
Apr 20, 2020
Messages
7
Reaction score
0
Points
1
Location
Georgia
Grill
Pro 570
I reset my router and the grill and got it to go back to showing its own network name. Now it still won't connect to my phone. It is still saying unable to connect when I try to do it. I've Uninstalled the app twice and nothing.
 
OP
OP
B

Bigblue09

New member
Joined
Apr 20, 2020
Messages
7
Reaction score
0
Points
1
Location
Georgia
Grill
Pro 570
I finally got it to work! I couldn't say for sure how I did it but I believe the issue is with the phones app permissions. It kept asking what network to pair with the grill but it would only give me the option to use the traegers network. After a few attempts I had it try to pair with the traeger network then went into settings and changed it back to home network really quick and it went through. I guess we will see how long this works. 30th time is a charm I guess.
 

MikeyR

Active member
Joined
Feb 23, 2020
Messages
210
Reaction score
52
Points
28
Location
Calgary
Grill
Ironwood 650
Nice! I found I’ve had to forget the Traeger network in the past to get it to work.
 

Latest Discussions

Top