New Controller - won’t connect Fixed

Crhage

New member
Joined
Jun 21, 2020
Messages
5
Reaction score
0
Points
1
Location
USA
Grill
Pro575
Here’s another thread about connecting. I’ve done everything recommended to date (I think) and Traeger even sent me a new controller.

After countless hours on the phone with CS and trying everything I’ve read, here’s the one thing no one thought of or recommended. This worked!!!

CS kept telling me to forget my 5ghz WiFi network on my phone. I did that. Did not work.

What I discovered is that my ASUS router defaults to the 5ghz network for all devices if it can and reserves the highest speeds for that network. Sooooo, it didn’t matter what network my phone was on, every time the grill and phone tried to handoff to the router, it tried to connect to the 5ghz.

CS could probably save folks a lot of time by saying specifically to “turn off the 5ghz network on your router, in addition to ignoring it on your phone”.

That’s exactly what I did and it connected right away.

Hope this helps someone!
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
535
Reaction score
155
Points
43
Location
King County, WA State, US
Grill
PRO 780
Here’s another thread about connecting. I’ve done everything recommended to date (I think) and Traeger even sent me a new controller.

After countless hours on the phone with CS and trying everything I’ve read, here’s the one thing no one thought of or recommended. This worked!!!

CS kept telling me to forget my 5ghz WiFi network on my phone. I did that. Did not work.

What I discovered is that my ASUS router defaults to the 5ghz network for all devices if it can and reserves the highest speeds for that network. Sooooo, it didn’t matter what network my phone was on, every time the grill and phone tried to handoff to the router, it tried to connect to the 5ghz.

CS could probably save folks a lot of time by saying specifically to “turn off the 5ghz network on your router, in addition to ignoring it on your phone”.

That’s exactly what I did and it connected right away.

Hope this helps someone!

The Airplane Mode Workaround that is discussed here in various messages/threads also works ...

Failed / Hung Setup of WiFIRE | Airplane Mode Workaround

ISSUE: Multiple people have reported that the initial setup of WiFIRE will fail/hang before completion ... this is due to the App device defaulting back to the "preferred" 5GHz Wireless Network after handing off the necessary 2.4GHz Wireless Network information to the Grill (Network Name (SSID), Encryption Type, Password). The App Device MUST reconnect back to the 2.4GHz Home Wireless Network in order for the setup process to successfully complete.

WORKAROUND: The best way to eliminate the failed/hung setup state for WiFIRE is to first put your App Device into Airplane Mode, then manually turn Wi-Fi back on, then "forget" the 5GHz Wi-Fi network, then connect to the 2.4GHz Wi-Fi network and start the setup process from the beginning ... this eliminates any potential issues with regards to the App Device reconnecting back to the wrong (i.e. 5GHz) Home Wi-Fi Network during the setup process ... once the setup process has successfully completed, you can take the App Device out of Airplane Mode, and reconnect to the 5GHz Wireless network on your App Device (if desired) ...
 
OP
OP
C

Crhage

New member
Joined
Jun 21, 2020
Messages
5
Reaction score
0
Points
1
Location
USA
Grill
Pro575
My post was specifically NOT about doing anything with the phone. Multiple people, including myself, did the airplane mode thing and it didn’t work. That only changes the phone setting and doesn’t impact the actual router. For people who have tried the airplane mode thing and everything else, do as I suggest and completely shut off the 5ghz network using your router software. After everything is connected, turn it back on.
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
535
Reaction score
155
Points
43
Location
King County, WA State, US
Grill
PRO 780
My post was specifically NOT about doing anything with the phone. Multiple people, including myself, did the airplane mode thing and it didn’t work. That only changes the phone setting and doesn’t impact the actual router. For people who have tried the airplane mode thing and everything else, do as I suggest and completely shut off the 5ghz network using your router software. After everything is connected, turn it back on.

Turning off the 5GHz frequency is one way to get around the required "stickiness" for the App Device to reconnect back to the 2.4GHz at the end of the setup process, but the inability to successfully complete setup has everything to do with the App Device and its default behaviors of connecting to preferred networks after being connected to some other external network previously (i.e. Traeger-XXXX) ... the 5GHz frequency is always preferred to a 2.4GHz frequency due to increased bandwidth and the number of available channels ... this is assuming that the 2.4GHz and 5GHz Network Names (SSIDs) are different than one another ...

Not disagreeing with you that it is a valid workaround step to try if everything else fails, but there are mesh network vendors who do not provide end users the ability to control the radios within the Router, such that the 5GHz frequency can only be turned off temporarily by vendor support for a relatively short window of time ... so that adds another layer of complexity with regards to making that temporary change ...
 
Last edited:
OP
OP
C

Crhage

New member
Joined
Jun 21, 2020
Messages
5
Reaction score
0
Points
1
Location
USA
Grill
Pro575
“but the inability to successfully complete setup has everything to do with the App Device and its default behaviors of connecting to preferred networks after being connected to some other external network previously (i.e. Traeger-XXXX) ...”

This is the type of thing I was trying to avoid in this thread. Please stop hijacking this.

The simple solution for a lot of people will be to just turn off the 5 ghz network using their router app.

There are already hundreds of threads explaining everything you said. That’s not the intent of this thread.
 
OP
OP
C

Crhage

New member
Joined
Jun 21, 2020
Messages
5
Reaction score
0
Points
1
Location
USA
Grill
Pro575
“Turning off the 5GHz frequency is one way to get around the required "stickiness" for the App Device to reconnect back to the 2.4GHz at the end of the setup process, “

That’s what this thread is about. It’s not about the possible other solutions.
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
535
Reaction score
155
Points
43
Location
King County, WA State, US
Grill
PRO 780
“but the inability to successfully complete setup has everything to do with the App Device and its default behaviors of connecting to preferred networks after being connected to some other external network previously (i.e. Traeger-XXXX) ...”

This is the type of thing I was trying to avoid in this thread. Please stop hijacking this.

The simple solution for a lot of people will be to just turn off the 5 ghz network using their router app.

There are already hundreds of threads explaining everything you said. That’s not the intent of this thread.

So if someone reads this thread first, and then attempts to find out how they turn off the 5GHz radio via their App, only to discover that their vendor does not provide that capability, you don't think having feedback in this thread that they may not have the ability to perform that specific action without contacting the vendor directly, is not useful?

I would suggest taking a moment to consider that specific point ... as it is referenced above ...
 
Last edited:
OP
OP
C

Crhage

New member
Joined
Jun 21, 2020
Messages
5
Reaction score
0
Points
1
Location
USA
Grill
Pro575
Nope. After spending so much time trying everything and reading so many threads with every possible solution under the sun, and after spending hours on the phone with CS and hours on hold, and after waiting more than a month for a new controller, I really think it’s best for people to start with turning off their 5ghz network from their router app (or by calling their router company) before they start the grill connection process. Just skip everything else you’ve heard. By turning off the 5ghz network you eliminate the need to do 4 or 5 of the other suggested fixes because you don’t give your phone or the grill the 5ghz network to connect to. It’s just simply not there if you try this first.

Try this first. If this doesn’t work, read the other various threads that list the 20 other ways to try to connect.
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
535
Reaction score
155
Points
43
Location
King County, WA State, US
Grill
PRO 780
Nope. After spending so much time trying everything and reading so many threads with every possible solution under the sun, and after spending hours on the phone with CS and hours on hold, and after waiting more than a month for a new controller, I really think it’s best for people to start with turning off their 5ghz network from their router app (or by calling their router company) before they start the grill connection process. Just skip everything else you’ve heard. By turning off the 5ghz network you eliminate the need to do 4 or 5 of the other suggested fixes because you don’t give your phone or the grill the 5ghz network to connect to. It’s just simply not there if you try this first.

Try this first. If this doesn’t work, read the other various threads that list the 20 other ways to try to connect.

The issue with your recommendation is that this isn't a long term "solution" - many of the Traeger troubleshooting scenarios require running through the setup process again when the App and WiFIRE Controller are no longer communicating through the Traeger Cloud back-end ...

By shutting off a working Wi-Fi radio, all of the devices that were attached to that frequency get disconnected, which may potentially necessitate rebooting some/many of those devices to get them to reattach to the 5GHz radio once it has been re-enabled ... this is going to create a LOT of challenges for a majority of users, most of whom are non-technical and may not know where everything is that requires a "reboot" ... you would be surprised by the % of people still renting their Router / Wireless Access Point from their ISP who have no idea, or desire, to know how to go in and manage that device via an App or Web Portal ...

These boards/FB groups represent a small fraction of Traeger's overall customer base ... and most people who come to these places do so looking for assistance/feedback, and/or to gripe about a bad experience ... collectively, they do not represent a significant percentage of Traeger customers ...

Providing guidance for setting up an IoT device using an extreme edge case scenario, versus following the prescriptive guidance that will work for 93-97%+ of that vendor's customer base, is a precedent no company is going to follow, because it introduces too many unknowns for the end user relative to other devices operating on that same Wi-Fi Network ... you may not agree with it, but speaking from the perspective of 30+ years in Enterprise Networking & Security + over a decade in Cloud & IoT, it is what it is ...

Lastly, given my experiences and time spent assisting a lot of people struggling to get their WiFIRE Controller connected to their Home Wi-Fi Network, the only time they have ever had to resort to disabling the 5GHz radio is on a Mesh Network product that would not provide an option for generating separate SSIDs (so it was a temporary measure, much like the one you describe that worked for you), or they had to utilize a Wi-Fi Extender, and since the Extender was only going to be servicing the WiFIRE Controller, to eliminate any confusion, it made more sense to configure it for 2.4GHz only and give it a separate SSID (so that person had 3 SSIDs within their Home Network and could easily distinguish which one to connect to via the App Device for running setup) ... both of these examples are the exception, not the rule ... and do represent the extreme edge case scenarios ...

EDIT: The long term solution is to be able to setup / re-setup the WiFIRE Controller with the Router / Wireless Access Point running in its normal day-to-day state ... and for 97%+ of the overall customer base, that can be achieved with the 2.4GHz & 5GHz radios both active ...
 
Last edited:

BigP

New member
Joined
Dec 28, 2020
Messages
3
Reaction score
3
Points
3
Location
South Jordan, UT
Grill
Timberline 1300
FWIW...with my Asus router, naming the 2.4 and 5 ghz channels separately did not work for me. After hours and hours of trying everything mentioned, I too had to temporarily shut off the the 5ghz channels in order to get my Traeger to connect. The only thing I would add to Crhage's advice, is that after shutting off the 5ghz channel, I had to reboot my phone (iPhone X), reboot my router, and then unplug and plug back in my Traeger (make sure your Traeger is not in use when connecting). After everything was freshly reset after disabling the 5ghz channel, did my Traeger finally connect. Hallelujah!!! Once connected, I turned the 5ghz channel back on and every device in the house was happy again.

I have owned a handful of different routers over the last couple of years, and I have found that with some routers, the Traeger will connect immediately and without issue. With other routers, you have to find the right combination of settings that will enable the connection. With Asus routers, I too highly recommend disabling the 5ghz channels while attempting to connect. That is the only combination I've found to work.
 
Last edited:

RickW

New member
Joined
Dec 7, 2020
Messages
16
Reaction score
1
Points
3
Location
CO
Grill
Timberline1300
Just set up a dedicated 2.4 network for the grill. Turn off all others on your phone and set up grill. Name the new network something fun because your neighbors can see it! After grill is set up, connect to your 5 or 10g on your phone
 
Top