Ignite button weirdness

SkipMorrow

New member
Joined
Nov 29, 2020
Messages
18
Reaction score
6
Points
3
Location
Virginia, USA
Grill
Pro 780
I've only done one cook so far with my new Pro 780. Ok, two if you count the seasoning. One thing that stuck out though, was when I was starting the grill for the wings, the ignite button seemed squishy. No real clickiness at all. But the problem was I had to push it several times. I even tried turning the grill on and off a few times. I just tried the ignite button again, and now it is working fine. So I was wondering, maybe I was doing something wrong? Or are people's ignite buttons somewhat unreliable?
 

RemE

Moderator
Staff member
Joined
Jun 10, 2019
Messages
1,460
Reaction score
987
Points
113
Location
Corona Del Mar, California
Grill
Timberline 850
Squishy is a good description, mine is similar in that it doesn't have a good tactile feel. One guy went inside of his controller and shaved a bit of plastic between the PC board and face, but that's an advanced maneuver for those who are qualified and comfortable tinkering.
 

RealMenDIY

Member
Joined
Jul 25, 2020
Messages
43
Reaction score
30
Points
18
Location
Georgia
Grill
Pro 780
Mine is squishy too. Just want to make sure that you are are doing the correct startup procedure because this tripped me up a few times when I first started using it: turn dial to desired temp > press dial knob in to lock temp > press ignite button. If you are following this procedure you may just have a temperamental ignite button.
 

Latest Discussions

Top