Help! D2 575 shutting down - any help wanted!

Wildonion

New member
Joined
May 24, 2020
Messages
5
Reaction score
2
Points
3
Location
London
Grill
D2 575 Pro
Hey all

Ive got a month old 575 and its been fine until this morning when i wanted to do a brisket.
I set the temp and the fan came on like it was igniting then it just went dead. Screen went off and had to start again.
After about 10 tries, to finally fired up. The pellets ignited and it went past the target temp. Then on the way down, it shut down again.
Now it wont even get to the menu screen, shows me the Traeger logo then goes dark. Don't think its the heat rod, or fan... like the controller is shutting it down. ..but have no idea.
Any idea what's going on?
Help appreciated.
 

Ek575

New member
Joined
May 23, 2020
Messages
12
Reaction score
2
Points
3
Location
Ireland
Grill
Pro 575
Try turning off WiFi and then turn on the grill and select forget network from the WiFi settings.

I have the same problem with a brand new 575. Connecting to WiFi kills the controller.

Seems to be an issue with the new firmware
 
OP
OP
W

Wildonion

New member
Joined
May 24, 2020
Messages
5
Reaction score
2
Points
3
Location
London
Grill
D2 575 Pro
Try turning off WiFi and then turn on the grill and select forget network from the WiFi settings.

I have the same problem with a brand new 575. Connecting to WiFi kills the controller.

Seems to be an issue with the new firmware
Ah, turn off the family wifi!?!?! that will cause trouble!

Ok...thanks for the tip...i'll give it a go.
 

Ek575

New member
Joined
May 23, 2020
Messages
12
Reaction score
2
Points
3
Location
Ireland
Grill
Pro 575
You can also try to navigate to forget network in the short time before the screen goes blank. I managed this the first time I connected, shutting off WiFi at that time wasn't an option
 
OP
OP
W

Wildonion

New member
Joined
May 24, 2020
Messages
5
Reaction score
2
Points
3
Location
London
Grill
D2 575 Pro
You can also try to navigate to forget network in the short time before the screen goes blank. I managed this the first time I connected, shutting off WiFi at that time wasn't an option
Yes, might try that.

However, for a bloody expensive bit of kit, its rubbish...ive had to oven bake a 6kg brisket today when i was meant to be doing a shared BBQ with mates in the US.
 
OP
OP
W

Wildonion

New member
Joined
May 24, 2020
Messages
5
Reaction score
2
Points
3
Location
London
Grill
D2 575 Pro
You can also try to navigate to forget network in the short time before the screen goes blank. I managed this the first time I connected, shutting off WiFi at that time wasn't an option
Thats worked! Really appreciate your help.

Shame i had to cook the brisket in the oven...nothing to BBQ now!
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
464
Reaction score
136
Points
43
Location
Western WA State, US
Grill
PRO 780
Thats worked! Really appreciate your help.

Shame i had to cook the brisket in the oven...nothing to BBQ now!
Contact Traeger Support - your WiFIRE Controller is susceptible to Firmware corruption and the May Update is the "cause" ... Traeger is determining if they can "fix" the issue programmatically, or if they will need to send you out a new controller ... in the interim, leaving the WiFIRE Controller disconnected from your Home Wi-Fi will allow you to run the grill directly from the display ...
 
OP
OP
W

Wildonion

New member
Joined
May 24, 2020
Messages
5
Reaction score
2
Points
3
Location
London
Grill
D2 575 Pro
Contact Traeger Support - your WiFIRE Controller is susceptible to Firmware corruption and the May Update is the "cause" ... Traeger is determining if they can "fix" the issue programmatically, or if they will need to send you out a new controller ... in the interim, leaving the WiFIRE Controller disconnected from your Home Wi-Fi will allow you to run the grill directly from the display ...
Thanks Dunaway Family!...yes, already sent them a rather curt email. Will follow up Tuesday.

Annoying that £100 of brisket went in the oven instead...
 

Nednapalm

New member
Joined
May 25, 2020
Messages
1
Reaction score
0
Points
1
Location
UK
Grill
Pro 575
Hey All - just joined after finding this thread, was about to go crazy over this issue, my new 575 broken already - I could almost hear a friend who is a BBQ “traditionalist” laughing at me even with lockdown distance!

I’ve made a little bit of progress on this - let me share what I did.

1. Multiple forget WiFi/remove from App doesn’t seem to resolve the issue - issue just keeps coming back as soon as you re-pair to the app.
2. Just did a factory reset (go to about grill, hold in Ignite button until logo appears, power off/on, go back in and check and ensure the WiFi network is forgotten.
3. Re-paired after factory reset seemed to trigger a full firmware update/reset and now I’m in a situation where I have 2.01.02 on the grill and 04.012 config, grill is paired to the app and is not crashing out any more - WiFire is working - even after a power off/on.

I’m going to leave it powered up for 24-48 to see if the config version comes down before I call the UK distributor.

Not sure if this will help everyone - will keep posting with any updates, but sure seems like the new firmware is problematic.

Ta, John.
 

adammorr

New member
Joined
May 28, 2020
Messages
1
Reaction score
1
Points
1
Location
Wiltshire
Grill
Pro 570
Hi everyone!

Like Nednapalm, I joined the forum for this thread so thanks for the information on a temporary workaround!

I spoke with Traeger yesterday and they've said to keep an eye on https://www.traegergrills.com/status for updates around this issue...🤞 it doesn't take too long

Adam
 
Top