Another new guy from Texas

Bully

New member
Joined
Nov 19, 2020
Messages
5
Reaction score
1
Points
3
Location
Dallas, TX
Grill
Timberline 850, PTG+
Howdy folks! I have a PTG+ (2 1/2 years) and a Timberline 850 (6 months). I found this site looking for answers as to why it takes 20-30 minutes for the Timberline
to start-up. Still working on that, starting to think it's related to the pellets I was using. I fought like crazy to get the PTG+ working like it should, so I may have some
answers as far as that goes. - Bully
 

John S.

Active member
Joined
Jul 12, 2020
Messages
137
Reaction score
35
Points
28
Location
San Mateo Ca.
Grill
Timberline 1300
Mine takes, about 15 min but it also tells me that it is at temp, before it really is, I give the 1300 about 30 - 45 min to come to temp and stabilize... if over 300 maybe an hr to stabilize....
temps measured on an FB ....
 

RemE

Moderator
Staff member
Joined
Jun 10, 2019
Messages
838
Reaction score
413
Points
63
Location
Corona Del Mar, California
Grill
Timberline 850
Howdy folks! I have a PTG+ (2 1/2 years) and a Timberline 850 (6 months). I found this site looking for answers as to why it takes 20-30 minutes for the Timberline
to start-up. Still working on that, starting to think it's related to the pellets I was using. I fought like crazy to get the PTG+ working like it should, so I may have some
answers as far as that goes. - Bully
Mine ignites, putting out smoke, in 5-10min, then up to the set temp. It used to take 20+ min to begin smoking and sometimes gave error messages about slow start.

I contacted Traeger support and they sent me a new Firepot/Hotrod assembly and it fixed the issue, been good ever since.

Worth a call,

Welcome aboard, from the hopelessly blue state!
 
OP
OP
B

Bully

New member
Joined
Nov 19, 2020
Messages
5
Reaction score
1
Points
3
Location
Dallas, TX
Grill
Timberline 850, PTG+
That's exactly the problem I'm having with mine. Takes 20+mins for smoke, error messages, etc. I moved the hotrod
out to 1/2" thinking that would help. After that I got my first failure to light/shutdown. And that was using Hickory from
Traeger. So after I got it up and running (manual light), I switched to Weber Hickory pellets and tried again the next day.
I had smoke in 12 minutes. I should just call Traeger and complain and see what they do about it.
 
Top