Another connectivity issue

AkBillyBow

New member
Joined
Jun 19, 2020
Messages
7
Reaction score
1
Points
3
Location
Alaska
Grill
Ironwood 885
Hello,

New here and new to the Traeger grill. Have a new Ironwood 885. Cooks great, but have not been able to connect to the Wifi. I will spare you all of the issues / things I have done (for almost a week now) and get right to todays issue. I got further along with the registration and connection to the wifi today than I have before. What does "Device to use with Traeger" refer to? During my initial connection, after scanning the QR code, a pop-up appears that asks: Device to use with Traeger. The first try, it automatically loads with my router.....then tells me I am connected to my router. Before the background screen of "checking wifi connection" will complete the connection, the "Device to use with Traeger" pop-up comes up again, but this time is auto filled with the name of my Traeger......then says wrong password. This cycle just continues and I cannot get past the window with it connected to use the app. I also have no way of choosing the device or entering a password.

What device is the "Device to use with Traeger" looking/ asking me for? I am very confused on how this works. The grill connects to the home wifi, yet I connect my phone to the grill? Please help. Love the grill....hate the wifi….which unfortunately was one of the big selling points !!
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
521
Reaction score
152
Points
43
Location
King County, WA State, US
Grill
PRO 780
To clarify a few things up front ... the only time the App Device connects 1:1 with the WiFIRE Controllers is during the setup process ... after setup is completed successfully, all communications are brokered via the Traeger Cloud back-end, allowing Traeger to collect usage data and perform analytics ...

Attaching a couple photos - is the WiFIRE Controller display matching the Connected State or the Disconnected State?

Since some folks have purchased grills in the past week that have been sitting in the dealers inventory for 8+ Months ... I gotta ask what are the installed Firmware and Config Version levels?

Your responses will dictate next steps :)
 

Attachments

  • Traeger | WiFIRE "Connected" State.jpg
    Traeger | WiFIRE "Connected" State.jpg
    136.8 KB · Views: 62
  • Traeger | WiFIRE "Disconnected" State.JPG
    Traeger | WiFIRE "Disconnected" State.JPG
    198 KB · Views: 58

NYRICO

New member
Joined
May 5, 2020
Messages
11
Reaction score
0
Points
1
Location
NY
Grill
Traeger Timberline 850
I was having problems with WiFire on my new Timberline 850. I tried a bunch of advice that I read on here and nothing worked. A few annoying CS calls with traeger and hours on hold and they finally determined that my controller was on the wrong firmware. A couple of more calls and 3 weeks wait and I received my controller and installed it today. WiFire was set up in a breeze as I expected from the beginning.
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
521
Reaction score
152
Points
43
Location
King County, WA State, US
Grill
PRO 780
I was having problems with WiFire on my new Timberline 850. I tried a bunch of advice that I read on here and nothing worked. A few annoying CS calls with traeger and hours on hold and they finally determined that my controller was on the wrong firmware. A couple of more calls and 3 weeks wait and I received my controller and installed it today. WiFire was set up in a breeze as I expected from the beginning.

You had obsolete/vintage firmware (1.x) running, which is no longer supported by the Traeger Cloud back-end or via the App ... it is discussed here and on various Traeger-related FB groups, but is not a well known "issue", hence people start giving out advice assuming the controller is running 2.00.01 at a minimum, when it is running 1.x ... only a controller swap with updated firmware will get the WiFIRE Controller setup/connected ...
 
OP
OP
A

AkBillyBow

New member
Joined
Jun 19, 2020
Messages
7
Reaction score
1
Points
3
Location
Alaska
Grill
Ironwood 885
OK, thanks for the help. Finally had time to check my grill. I have : Software: 02.00.01, Config Vers: 05.008.

Where does this leave me?

Thanks again for all of your help !!
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
521
Reaction score
152
Points
43
Location
King County, WA State, US
Grill
PRO 780
OK, thanks for the help. Finally had time to check my grill. I have : Software: 02.00.01, Config Vers: 05.008.

Where does this leave me?

Thanks again for all of your help !!

On the WiFIRE Controller Display - which picture represents what you are seeing in the upper right hand corner? Outline of an upside down triangle (Wi-Fi is disconnected), or Bars in the shape of an unside down triangle (Wi-Fi is connected) ...
 
OP
OP
A

AkBillyBow

New member
Joined
Jun 19, 2020
Messages
7
Reaction score
1
Points
3
Location
Alaska
Grill
Ironwood 885
On the WiFIRE Controller Display - which picture represents what you are seeing in the upper right hand corner? Outline of an upside down triangle (Wi-Fi is disconnected), or Bars in the shape of an unside down triangle (Wi-Fi is connected) ...

It is showing disconnected. It did show connected once and started the upgrade download, but it never got off of 0%. My phone shows connected to my wifi as well as connected to the grill, during the initial software set-up and registration of the grill. But then it always tells me there was an issue and never completes the registration.
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
521
Reaction score
152
Points
43
Location
King County, WA State, US
Grill
PRO 780
The App on the phone is providing "bad data" - either bad data stored locally in the cache of the App on the device, or bad data stored in the Traeger Cloud relative to the connectivity status of the WiFIRE Controller itself ... I would delete the App on phone and purge the cache, and then Factory Reset the WiFIRE Controller, power cycle the grill, re-install the App, and start the setup process fresh ... from that point, troubleshooting whatever comes up during a "clean" setup ...
 
OP
OP
A

AkBillyBow

New member
Joined
Jun 19, 2020
Messages
7
Reaction score
1
Points
3
Location
Alaska
Grill
Ironwood 885
I have already done that once, but will try it again. I didn't remember my password for the Traeger app....so I had to reset it too!!

Thanks again for your help !
 
OP
OP
A

AkBillyBow

New member
Joined
Jun 19, 2020
Messages
7
Reaction score
1
Points
3
Location
Alaska
Grill
Ironwood 885
Please explain one more thing.....does my phone ever connect directly to the grill? It continually shows it attempting a connection to the wifi (which is normally successful), then it goes right to connecting the phone app to the grill itself (by grill wifi name). Should this connection ever be made? I am thinking I read where you said it all goes through the home wifi then to the Traeger cloud......meaning my phone should never connect directly to the grill.
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
521
Reaction score
152
Points
43
Location
King County, WA State, US
Grill
PRO 780
Please explain one more thing.....does my phone ever connect directly to the grill? It continually shows it attempting a connection to the wifi (which is normally successful), then it goes right to connecting the phone app to the grill itself (by grill wifi name). Should this connection ever be made? I am thinking I read where you said it all goes through the home wifi then to the Traeger cloud......meaning my phone should never connect directly to the grill.

Only during the setup process is there a 1:1 connection - at the point your App Device joins Traeger-XXXX (unique name for your WiFIRE Controller's internal network) - this is when it hands off the Home Wi-Fi Network information (Network Name (SSID), Encryption Type, and Password (which you type in)) ... once this point of the setup process completes, then your phone rejoins your Home Wi-Fi Network, as does the WiFIRE Controller, and all communications from that point forward are brokered by the Traeger Cloud back-end ...
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
521
Reaction score
152
Points
43
Location
King County, WA State, US
Grill
PRO 780
There are a few reasons why the setup process fails - they are almost always a result of the configuration of the Router / Wireless Access Point and/or the App Device ... I will paste in the first few things to review:

-----------
First step in troubleshooting issues with WiFIRE: One thing to verify on your end is the need to use separate network names (SSIDs) for the 2.4GHz and 5GHz Wireless frequencies - depending on what WiFi Router/Access Point you use, as well as what mobile device you are using to run the app on, it may be a requirement ... when the network names are the same, and if your mobile device supports 5GHz, the mobile device will by default attach to the 5GHz frequency, while the Grill is connected on the 2.4GHz frequency, resulting in no connection between the App and the Grill ... giving one of the wireless network frequencies a different name allows you to "force" the mobile device to attach to the 2.4GHz network and successfully connect ...

I call my IOT-based device Wireless Networks...
idIOT
idIOT 5GHz
...to support this specific scenario

Additional troubleshooting scenarios and information listed here:
https://www.traegergrills.com/support/wifire-controllers
https://www.traegergrills.com/support/wifire-troubleshooting

WiFIRE Troubleshooting Wizard: http://wizard.web.traegergrills.io/wifire/welcome
-----------

Failed / Hung Setup of WiFIRE | Airplane Mode Workaround

ISSUE: Multiple people have reported that the initial setup of WiFIRE will fail/hang before completion ... this is due to the App device defaulting back to the "preferred" 5GHz Wireless Network after handing off the necessary 2.4GHz Wireless Network information to the Grill (Network Name (SSID), Encryption Type, Password). The App Device MUST reconnect back to the 2.4GHz Home Wireless Network in order for the setup process to successfully complete.

WORKAROUND: The best way to eliminate the failed/hung setup state for WiFIRE is to first put your App Device into Airplane Mode, then manually turn Wi-Fi back on, then "forget" the 5GHz Wi-Fi network, then connect to the 2.4GHz Wi-Fi network and start the setup process from the beginning ... this eliminates any potential issues with regards to the App Device reconnecting back to the wrong (i.e. 5GHz) Home Wi-Fi Network during the setup process ... once the setup process has successfully completed, you can take the App Device out of Airplane Mode, and reconnect to the 5GHz Wireless network on your App Device (if desired) ...
 

Bgilmore

New member
Joined
Jun 14, 2020
Messages
12
Reaction score
1
Points
3
Location
Orange County, CA
Grill
Pro 575
I’ve tried all of these things and still nothing. I received a survey from traeger today asking if the warranty part I received fixed the prob?! Seriously? What part was that? I never received anything. I left a detailed description on the first traeger survey about this POS grill that cannot connect to WiFi. No one has contacted me. I refuse to call customer service again. So bummed about this whole experience- will never recommend a traeger to anyone. ?
 

Bgilmore

New member
Joined
Jun 14, 2020
Messages
12
Reaction score
1
Points
3
Location
Orange County, CA
Grill
Pro 575
I was having problems with WiFire on my new Timberline 850. I tried a bunch of advice that I read on here and nothing worked. A few annoying CS calls with traeger and hours on hold and they finally determined that my controller was on the wrong firmware. A couple of more calls and 3 weeks wait and I received my controller and installed it today. WiFire was set up in a breeze as I expected from the beginning.
How can you skip the overseas CS calls and go straight to someone who can actually help? I’m in the same boat- my grill connected when it was first setup but never again. The app can’t find Wi-Fi. I’ve tried every combination of any tips found here on on YouTube and nada. If you have any email addresses from someone you dealt with, could I get it from you?
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
521
Reaction score
152
Points
43
Location
King County, WA State, US
Grill
PRO 780
I’ve tried all of these things and still nothing. I received a survey from traeger today asking if the warranty part I received fixed the prob?! Seriously? What part was that? I never received anything. I left a detailed description on the first traeger survey about this POS grill that cannot connect to WiFi. No one has contacted me. I refuse to call customer service again. So bummed about this whole experience- will never recommend a traeger to anyone. ?

I can help if you want to step through everything ... if the D2 WiFIRE Controller is running firmware 2.00.01 (or later), then the issue is usually tied to the configuration within the Router / Wireless Access Point and/or the App Device ... if the firmware version is 2.00.00 or earlier, you need a replacement controller ... reach out if you want to dive into the specifics of troubleshooting ...
 

Docholliday29

New member
Joined
Jun 23, 2020
Messages
10
Reaction score
3
Points
3
Location
Jefferson, GA
Grill
Ironwood 885
My new Ironwood 885 wifire issues were resolved within 30 minutes when I called customer service ( on my first call). I called 6/18/20.

the tech, asked me to move my router closer, power off the grill and it worked. Maybe he recommended more but that is all I recall.
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
521
Reaction score
152
Points
43
Location
King County, WA State, US
Grill
PRO 780
My new Ironwood 885 wifire issues were resolved within 30 minutes when I called customer service ( on my first call). I called 6/18/20.

the tech, asked me to move my router closer, power off the grill and it worked. Maybe he recommended more but that is all I recall.

The main issue I have been seeing assisting people the past couple weeks is Firmware version related ... if the grill has a Gen1-based controller (AC-powered), Traeger has ceased supporting anything prior to version 3, thus you have to get a controller replacement sent out ... If the grill has a Gen2-based controller (D2 WiFIRE Controller) running Firmware version 2.00.00 or earlier, a replacement controller is needed to be able to complete the setup process ... I have seen people complaining about how their WiFIRE Controller was connected and working and now it isn't ... if their grill is still running version 2.00.00 or earlier of the Firmware, recent changes have been made to the App & Traeger Cloud back-end essentially making old Firmware versions non-functional/obsolete relative to Wi-Fi Setup/Connectivity ...

If the Gen2-based controller has Firmware version 2.00.01 or later, it "should" work, assuming that the Router / Wireless Access Point & App Device are tweaked to accommodate the specific requirements to get through the setup process ... There is a bit of nuance in getting everything "lined up" initially to allow the setup process to successfully complete (especially if you had to get a controller replacement and have numerous failed attempts trying to get the old non-functioning controller connected) ... is it possible someone has a controller with corrupted Firmware, and due to that corruption the setup process is failing? Yes ... but that would be extremely rare ... but I have been involved in a couple of those so far ...

Traeger Support is not prepared to deal with all the possible variations of what an end user may have installed ... the if-then-this diagram can get convoluted fairly quickly depending on the Make/Model of Router, whether there are Wi-Fi Extenders in the mix (+ are they Single or Dual-band Extenders), if the Router is Dual-band Wi-Fi 5 (802.11ac) versus Mesh-based, if the Router is Wi-Fi 6 (802.11ax), the age of the App Device, etc.

To date, I have assisted over 50 people in the past few months - the end result was either a working solution (i.e. WiFIRE Controller connected and manageable via the App), that also provides them the ability to re-run setup "as needed" for troubleshooting purposes, or definitive confirmation that the WiFIRE Controller needs to be replaced ... Willing to assist anyone who wants to go down the rabbit hole to end up with one of the two outcomes ...
 
OP
OP
A

AkBillyBow

New member
Joined
Jun 19, 2020
Messages
7
Reaction score
1
Points
3
Location
Alaska
Grill
Ironwood 885
Dunawayfamily ….thanks for your help. I am away from home on business, so will not get back to troubleshooting my grill for a while. Just an FYI (I was trying to keep it simple in the beginning), I had already read most of your posts and tried them before I wrote my own post. I am using a wifi extender ,after not getting a connection to my router originally. It is split (2G, 5G), I am not connecting at all to the 5G. Nothing is defaulting to the 5 G. I can connect my phone and my Kindle to the 2G connection without issues. And, they are named differently like you had suggested.

Thanks for your help. I will get back to you after I return home and continue the battle with the Wifi !!
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
521
Reaction score
152
Points
43
Location
King County, WA State, US
Grill
PRO 780
Dunawayfamily ….thanks for your help. I am away from home on business, so will not get back to troubleshooting my grill for a while. Just an FYI (I was trying to keep it simple in the beginning), I had already read most of your posts and tried them before I wrote my own post. I am using a wifi extender ,after not getting a connection to my router originally. It is split (2G, 5G), I am not connecting at all to the 5G. Nothing is defaulting to the 5 G. I can connect my phone and my Kindle to the 2G connection without issues. And, they are named differently like you had suggested.

Thanks for your help. I will get back to you after I return home and continue the battle with the Wifi !!

There is a possibility you have old Firmware on the WiFIRE Controller even if it is a fairly new grill ... I have chatted with a 3+ people in June who have purchased grills that had a Manufacturing Date of Oct 2019 and earlier, thus were running unsupported/vintage/obsolete Firmware right out-of-the-box ...

EDIT: Nevermind - you posted your version up near the top ... what you have should work, unless the installed Firmware is corrupted ...
 

Scuba1954

New member
Joined
Jun 24, 2020
Messages
1
Reaction score
1
Points
1
Location
45050
Grill
Pro 575
Hello,

New here and new to the Traeger grill. Have a new Ironwood 885. Cooks great, but have not been able to connect to the Wifi. I will spare you all of the issues / things I have done (for almost a week now) and get right to todays issue. I got further along with the registration and connection to the wifi today than I have before. What does "Device to use with Traeger" refer to? During my initial connection, after scanning the QR code, a pop-up appears that asks: Device to use with Traeger. The first try, it automatically loads with my router.....then tells me I am connected to my router. Before the background screen of "checking wifi connection" will complete the connection, the "Device to use with Traeger" pop-up comes up again, but this time is auto filled with the name of my Traeger......then says wrong password. This cycle just continues and I cannot get past the window with it connected to use the app. I also have no way of choosing the device or entering a password.

What device is the "Device to use with Traeger" looking/ asking me for? I am very confused on how this works. The grill connects to the home wifi, yet I connect my phone to the grill? Please help. Love the grill....hate the wifi….which unfortunately was one of the big selling points !!
I was unable to connect my pro 575 to the internet because the grill would not be allowed to talk to the wiring router. I was able after numerous tries to get the connection to work. I ended up having my phone search for wifi devices and it found the traeger grill. I clicked on that device and they chose the forget option. Then I opened the traeger app and re ran the pair program and everything was happy.
 
Top