575 pro, nothing but issues.

TheMagicNookie

New member
Joined
Apr 15, 2020
Messages
16
Reaction score
2
Points
3
Location
Oregon
Grill
Pro 575
I bought my Traeger yesterday, and have had nothing but problems. I understand most of these issues probably stem from needing the software update, but this is crazy. I need a WiFi booster before I can update which is disappointing in and of itself, my WiFi cuts off at my doorstep unfortunately.

The temperature swings are ridiculous. 20-40 degree swings up and down, I’m currently at almost 2 hours at 375 on a beer can chicken, the recipe called for just an hour and 15 min, however the calibrated probe read “cold” for the first 40 min of the cook and only broke 50 after an hour, I don’t trust it, a lot of others just doing quick reads on the forums don’t either, I pulled it to check but sure enough even at 2 hours it’s raw a 1/4” into the cut. Wow..... is it. It really 375 degrees? How could it be that much off from factory???

I see problem after problem with a lot of other people as well having the be sent new controllers, new probes, etc. why all the trouble on a literally brand new grill?

this is all incredibly frustrating, especially when I got quarantined elderly family waiting on food. will the update really fix all these issues? I attempted a small ribeye to test last night and had what I guess to be decent results but again, took 3-4x longer than told.
 

Gary

Member
Joined
Mar 9, 2020
Messages
136
Reaction score
24
Points
18
Location
California
Grill
Pro 575
Just wondering how did your seasoning of the unit go??
 
OP
OP
T

TheMagicNookie

New member
Joined
Apr 15, 2020
Messages
16
Reaction score
2
Points
3
Location
Oregon
Grill
Pro 575
Just wondering how did your seasoning of the unit go??
Did it to the letter according to the book, temp swings were about 20 degrees if not more.

I’ve gotten to the point where I’ve not dragged this thing into my office to get the update online, but now, nothing is working. I go to add the grill on the app, go through all the steps, most of the time the app just stays on the “grill connected” screen, and nothing happens. Three times now I’ve gotten all the way to the “nickname” the grill screen, everything checks out, but when it returns to the apps homepage, nothing is there. 0 grills, like I didn’t do anything. I’ve reset my phone 3 times, deleted and re downloaded the app 7 times, nothing works. The grill itself is apparently connected, but it’s useless without the app. Nothing’s updated as far as firmware, so I have no idea how I’m supposed to implement it. This is infuriating at this point....
 

Gary

Member
Joined
Mar 9, 2020
Messages
136
Reaction score
24
Points
18
Location
California
Grill
Pro 575
My unit is new as well maybe 2 weeks
.it hasn't downloaded the new firmwares!
Apparently mine needs 2. Have been on the phone with customer service 4 times and they told me to hold tight it will update. So I am giving it 10 days and I'll call again. My wifi and app work fine so in that regard I'm in a better situation than you. I would call customer service and get transferred up to a supervisor. You may very well need a new controller. But you need a case started and get it to a supervisor. Best of luck once you get it running it does work really well.
 
OP
OP
T

TheMagicNookie

New member
Joined
Apr 15, 2020
Messages
16
Reaction score
2
Points
3
Location
Oregon
Grill
Pro 575
And as I was about to give up, again, stuck on the “connected” screen, my grill itself starts randomly updating? Weird. I’m on the most current firmware now, apps working randomly out of the blue, i just hope it stays this way. I’m gonna try another cook tomorrow after work to see. I really hope this works out, I’ve been wanting this for about a year now and it’s been a disappointing experience so far.

Maybe I’m having internet issues on top of it all corrupting this process? I have the ISP on the phone now running the numbers. I guess for anyone having the same issues just stick it out. I feel like my post has been kind of scatter brained as far as what the issues are but maybe this might help someone.
 
OP
OP
T

TheMagicNookie

New member
Joined
Apr 15, 2020
Messages
16
Reaction score
2
Points
3
Location
Oregon
Grill
Pro 575
My unit is new as well maybe 2 weeks
.it hasn't downloaded the new firmwares!
Apparently mine needs 2. Have been on the phone with customer service 4 times and they told me to hold tight it will update. So I am giving it 10 days and I'll call again. My wifi and app work fine so in that regard I'm in a better situation than you. I would call customer service and get transferred up to a supervisor. You may very well need a new controller. But you need a case started and get it to a supervisor. Best of luck once you get it running it does work really well.
I hope it works out! I just posted what happened as you posted this^^^ maybe it keep screwing with it? I don’t need ow what I did, it just randomly started updating while my screen was stuck on the connecting screen!
 

MikeyR

Active member
Joined
Feb 23, 2020
Messages
205
Reaction score
47
Points
28
Location
Calgary
Grill
Ironwood 650
The biggest challenge is getting the update. Once that happens, everything typically fixes itself, especially if you can connect to the grill. Enjoy!
 
OP
OP
T

TheMagicNookie

New member
Joined
Apr 15, 2020
Messages
16
Reaction score
2
Points
3
Location
Oregon
Grill
Pro 575
Just to let everyone know the current situation, I managed to get a connection after pulling the grill inside my office to do an update. It was a pain in the ass, uninstalling the app, forgetting the WiFi in the grill a few times to reconnect, but after getting froze on the connection screen on the app, the grill controller started to update, and did it twice! Got bike from work and threw 2 tri tip on to see how it goes, out the grill in the front porch again same spot where I didn’t get any connectivity, and I’m good! App works fine, monitored the cook from the dog park about a mile away, temp swings are 5-10 degrees, and it took a couple calibration ms with the probe in the ice bath to read 32-33 but it does now, I have a fancy instant read on the way just in case. It’s been an hour now my IT is 116, right on so far! Super stoked!
 

Gary

Member
Joined
Mar 9, 2020
Messages
136
Reaction score
24
Points
18
Location
California
Grill
Pro 575
The biggest challenge is getting the update. Once that happens, everything typically fixes itself, especially if you can connect to the grill. Enjoy!
And I can't understand why it's so difficult to get the updates!!
 

MikeyR

Active member
Joined
Feb 23, 2020
Messages
205
Reaction score
47
Points
28
Location
Calgary
Grill
Ironwood 650
And I can't understand why it's so difficult to get the updates!!

I’ve never had an issue, until I tried the extra grill I have in my garage. It and my other grill had always updated instantly.
 

Walleye Hunter

Active member
Joined
Aug 29, 2019
Messages
226
Reaction score
57
Points
28
Location
PA
Grill
Pro 575
Mine just has a 20-30 degree difference between what the controller says it is vs what it actually is in there. Colder inside the box than what the controller reads.
 
OP
OP
T

TheMagicNookie

New member
Joined
Apr 15, 2020
Messages
16
Reaction score
2
Points
3
Location
Oregon
Grill
Pro 575
I'll have to wait till tuesday when my instant read thermometer gets in to see if there's any inaccuracy as far as real temps go. I did have a minor problem yesterday when going to 500, i don't know if another update will fix it or not but once it got to 500 for my reverse sear, the temp would go back down to 420 and hover, then down to 390. I ended up pulling the tri tips and throwing them on the Propane for a quick hot sear, wasn't about to let it ruin a good cook. I think i'll play with it later today or tomorrow to see if it'll go back to 500 and stay relatively there.
 

Gary

Member
Joined
Mar 9, 2020
Messages
136
Reaction score
24
Points
18
Location
California
Grill
Pro 575
Interesting mine did similar but I have yet to get the update. Yesterday 450 would drop 25 degrees and not really make it back to 450.
Today absolutely perfect!! Go figure maybe we need to break these beasts in. Chicken turned out amazing!!
 

Jmthornt

Member
Joined
Apr 21, 2020
Messages
32
Reaction score
20
Points
8
Location
Texas
Grill
Pro 575
I bought my Traeger yesterday, and have had nothing but problems. I understand most of these issues probably stem from needing the software update, but this is crazy. I need a WiFi booster before I can update which is disappointing in and of itself, my WiFi cuts off at my doorstep unfortunately.

The temperature swings are ridiculous. 20-40 degree swings up and down, I’m currently at almost 2 hours at 375 on a beer can chicken, the recipe called for just an hour and 15 min, however the calibrated probe read “cold” for the first 40 min of the cook and only broke 50 after an hour, I don’t trust it, a lot of others just doing quick reads on the forums don’t either, I pulled it to check but sure enough even at 2 hours it’s raw a 1/4” into the cut. Wow..... is it. It really 375 degrees? How could it be that much off from factory???

I see problem after problem with a lot of other people as well having the be sent new controllers, new probes, etc. why all the trouble on a literally brand new grill?

this is all incredibly frustrating, especially when I got quarantined elderly family waiting on food. will the update really fix all these issues? I attempted a small ribeye to test last night and had what I guess to be decent results but again, took 3-4x longer than told.
Hi. Touching base to see if things have changed. I’m new to the Traeger world. I was looking at getting the Pro 22, and elected, when HD couldn’t find the one they had in stock, to get the 575. Two weeks in and zero problems. The probe, definitely needed calibrating. I have an instant I trust, calibrated the internal probe 9 degrees. So there is that, but afterwards, perfect. If your WiFi is weak As you indicate, I can see where problems would surface. I read you need a WiFi booster, not knowing your internet speeds, house size, and modem range, I’ll tell you that I purchased googles 3 pack of WiFi “pucks” as I call them. You can buy then individually or a three pack. They are phenomenal. They communicate wirelessly, the first is wired into your modem. They eliminate dead spots and I Greatly enhance signal strength outdoors. There are other options too, but this was great for me. I’ve read the issues with the 575, but haven’t experienced, (knock on wood). I hope the issues you are having are simply internet signal related. A booster will help. Good luck.
 

rlaverda

Member
Joined
Apr 15, 2020
Messages
41
Reaction score
10
Points
8
Location
Oregon
Grill
Pro 575
I extended my wifi and have no problems with the app or connecting my grill to wifi. The grill temperature however is way off. I smoked a whole chicken using a Traeger recipe which was only supposed to take 3 hours & at the end of 6 hours it still wasn't done. I finished it in the oven. I calibrated the probe that came with the Traeger but it never corrected itself. I verified that with a Thermapro thermometer. The firmware upgrade is supposed to fix all of this, but it is unknown when we will get it. i have heard sometime this month, but Traeger will not give a definitive answer. This is very frustrating and calling them does nothing.
 

Jmthornt

Member
Joined
Apr 21, 2020
Messages
32
Reaction score
20
Points
8
Location
Texas
Grill
Pro 575
I extended my wifi and have no problems with the app or connecting my grill to wifi. The grill temperature however is way off. I smoked a whole chicken using a Traeger recipe which was only supposed to take 3 hours & at the end of 6 hours it still wasn't done. I finished it in the oven. I calibrated the probe that came with the Traeger but it never corrected itself. I verified that with a Thermapro thermometer. The firmware upgrade is supposed to fix all of this, but it is unknown when we will get it. i have heard sometime this month, but Traeger will not give a definitive answer. This is very frustrating and calling them does nothing.
I hope you are right and the firmware upgrades fixes. I have noticed in a couple of recipes it takes longer to get to an internal temp then they state. Not TWICE as long. I just bump it up to get to the temp. Yeah, a Traeger Isn’t cheap, should absolutely deliver. I have had a couple of questions and went into virtual hold but they never called back. The grill has been fine for me, their customer service hasn’t. But then again, I figured out my answers. I’m reading this firm upgrade should fix a lot of issues, bump up max temp. Custom cooking cycles. May be nice.
 
OP
OP
T

TheMagicNookie

New member
Joined
Apr 15, 2020
Messages
16
Reaction score
2
Points
3
Location
Oregon
Grill
Pro 575
Hi. Touching base to see if things have changed. I’m new to the Traeger world. I was looking at getting the Pro 22, and elected, when HD couldn’t find the one they had in stock, to get the 575. Two weeks in and zero problems. The probe, definitely needed calibrating. I have an instant I trust, calibrated the internal probe 9 degrees. So there is that, but afterwards, perfect. If your WiFi is weak As you indicate, I can see where problems would surface. I read you need a WiFi booster, not knowing your internet speeds, house size, and modem range, I’ll tell you that I purchased googles 3 pack of WiFi “pucks” as I call them. You can buy then individually or a three pack. They are phenomenal. They communicate wirelessly, the first is wired into your modem. They eliminate dead spots and I Greatly enhance signal strength outdoors. There are other options too, but this was great for me. I’ve read the issues with the 575, but haven’t experienced, (knock on wood). I hope the issues you are having are simply internet signal related. A booster will help. Good luck.


All my problems have since been resolved. I bought pucks as well, so i could get the grill off the porch next to the door. The updates worked for me, had to screw around with getting the app to work, but it figured itself out on its own. my probe was only off 3 degrees, i calibrated it, then my new Instant read came in the mail and sure enough was only off by a degree then as well! It's maintained calibration too. I tried some tri tip again seeing as that's what i mainly do weekly. It gets to 500 Okay, and reverse sears just fine, though i do leave it in for an extra minute (5 min each side) to let the grill get back to 500 and maintain that heat for the next flip. Did my first brisket(10lbs) for my birthday saturday, turned out kinda dry, but i did "keep warm" for about an hour and let it rest for 3 because we had to delay guest arrival due to unfortunate plumbing events. i'm sure if i pulled it out right away and rest only a half hour it would have been amazing, but my family said it was the best they had nonetheless and it was all gone by the next day between 7 people. Highly recommend the Smoked cilantro cream brisket taco recipe on the app! Not to mention the berry cobbler! (id double it for a 12 pan)

My only hope is a future firmware update bumps the max temp to 550 so i can maintain that 500 degree sear, and maybe even a super smoke option for the pro 575 lol i want to see what i'm missing out on.
 

Jmthornt

Member
Joined
Apr 21, 2020
Messages
32
Reaction score
20
Points
8
Location
Texas
Grill
Pro 575
All my problems have since been resolved. I bought pucks as well, so i could get the grill off the porch next to the door. The updates worked for me, had to screw around with getting the app to work, but it figured itself out on its own. my probe was only off 3 degrees, i calibrated it, then my new Instant read came in the mail and sure enough was only off by a degree then as well! It's maintained calibration too. I tried some tri tip again seeing as that's what i mainly do weekly. It gets to 500 Okay, and reverse sears just fine, though i do leave it in for an extra minute (5 min each side) to let the grill get back to 500 and maintain that heat for the next flip. Did my first brisket(10lbs) for my birthday saturday, turned out kinda dry, but i did "keep warm" for about an hour and let it rest for 3 because we had to delay guest arrival due to unfortunate plumbing events. i'm sure if i pulled it out right away and rest only a half hour it would have been amazing, but my family said it was the best they had nonetheless and it was all gone by the next day between 7 people. Highly recommend the Smoked cilantro cream brisket taco recipe on the app! Not to mention the berry cobbler! (id double it for a 12 pan)

My only hope is a future firmware update bumps the max temp to 550 so i can maintain that 500 degree sear, and maybe even a super smoke option for the pro 575 lol i want to see what i'm missing out on.
That’s great! I don’t have the update yet. Looking forward to seeing how it performs. Did the custom cooking cycles come out with the 500 max update? Sounds like things are going good for you now. Good to read!
 

peter_c_morris

New member
Joined
May 5, 2020
Messages
1
Reaction score
0
Points
1
Location
Park City, Ut
Grill
Model 22
I had a lil Tex for years and loved it. My wife bought me a 575 last summer and I gave my old one to my son in law. First time we used it I thought the temperatures seem low, in fact steaks just never got hot enough. We tried a few of the recipes we had been doing over the years and everything was too low even though the temperature said it was ok. A separate thermometer confirmed the issue, the Traeger seemed to run about 30-50 degrees low. Also the 575 seemed to churn through more pellets, it is bigger than the lil Tex and model 22 but I really never need anything bigger. Tried to reach out to Traeger but could never get through. Returned it to Home depot and got a pro model 22. Love it, just like the old one, everything cooks perfectly. I hear they have done some work on firmware updates but forums seem to indicate people are still not happy. What a pity, I sure hope they fix it.
 
Top