Ranger | Meat Probe Temp Issue | Error P17 and P-40

NicoB

New member
Joined
May 23, 2022
Messages
2
Reaction score
1
Points
3
Location
France, Strasbourg
Grill
Ranger
Hello everybody,

I bought recently the "Ranger" (model "TFT18KLDE-2011-VW-01663")
Firmware version : v.00.18.08

It's perfect for cooking outside, in camp, .. ! 🏕️🏕️
I really appreciate this little model.


But, I have a meat probe issue ..
:cry:
1/ I plug the meat prob sensor into the controller
2/ Then I push central button 2 times to go in meat prob menu
3/ I press the "UP" button several times to select target temperature (for example 194 °F) then press central button to commit
4/ And problem, .. I always get the message "P-40"
I tried to put the meat prob into a bucket of ice, nothing change -> always "P-40"
I tried into a hot cup of water (approx. 212 °F) -> nothing change -> always "P-40" message

ErrorP-40.jpg



After several couple of minutes, or if I unplug the meat prob sensor, I get the message "P 17"
:cry:
ErrorP17.jpg


Cooks, experts,
Please, can you tell me what's wrong ? how can I fix this ?
I really want to repair this meat prob sensor for cooking and improve myself,
and .. I hope one day, join your team, the traegerhood ! 🤗
Thanks in advance,

Cheers,
Nicolas
 

JPSBBQ

Well-known member
Joined
Oct 24, 2021
Messages
380
Reaction score
348
Points
63
Location
Illinois
Grill
Tailgater,Ranger,Ironwood 885, Timberine 850 &1300
I would call Customer service. Not sure.
 

Bwoods1418

New member
Joined
May 23, 2022
Messages
1
Reaction score
0
Points
1
Location
North Carolina
Grill
Ranger
Hello everybody,

I bought recently the "Ranger" (model "TFT18KLDE-2011-VW-01663")
Firmware version : v.00.18.08

It's perfect for cooking outside, in camp, .. ! 🏕️🏕️
I really appreciate this little model.


But, I have a meat probe issue ..
:cry:
1/ I plug the meat prob sensor into the controller
2/ Then I push central button 2 times to go in meat prob menu
3/ I press the "UP" button several times to select target temperature (for example 194 °F) then press central button to commit
4/ And problem, .. I always get the message "P-40"
I tried to put the meat prob into a bucket of ice, nothing change -> always "P-40"
I tried into a hot cup of water (approx. 212 °F) -> nothing change -> always "P-40" message

View attachment 9429


After several couple of minutes, or if I unplug the meat prob sensor, I get the message "P 17"
:cry:
View attachment 9430

Cooks, experts,
Please, can you tell me what's wrong ? how can I fix this ?
I really want to repair this meat prob sensor for cooking and improve myself,
and .. I hope one day, join your team, the traegerhood ! 🤗
Thanks in advance,

Cheers,
Nicolas
I’m not sure you can use the probe to select the desired temp on the ranger. I just finally figured out today that once the probe is in place on the grill and in the meat, after the grill is up to the temp set, You push the center button 2 times to see what the meats current temp is. That is how I monitored my brisket today. Came out great.
 
OP
OP
NicoB

NicoB

New member
Joined
May 23, 2022
Messages
2
Reaction score
1
Points
3
Location
France, Strasbourg
Grill
Ranger
Hi,

Yes, I opened a case in support Traeger EU.
They send me a new controller (ref KIT0372)

ControllerRanger.png


I received the new controller today.
And I just replaced it on the ranger.

Traeger-Ranger-Repaired.png


Great, it now works with the new controller!
The meat probe with the temperature is well and correctly displayed on the screen, with a beep when the probe is connected (for its detection), then an other beep when the probe is disconnected.
The temperature is correct, and there are no more P-40 error messages displayed.
The problem really came from the old faulty controller.
Many thanks to LeMarquier FR support, and to Traeger EU :)
🏕️

Bye,
Nicolas
 
Top