Pro 780 shuts off 10 seconds after turning on

CF422

New member
Joined
May 21, 2020
Messages
21
Reaction score
7
Points
3
Location
Washington State
Grill
Pro 780
I turned my grill on tonight to start cooking. Once I turned it on I had to wait several minutes as the software update was taking place. Once finished I turned the grill to 350, let it preheat, and put on my chicken. I went outside shortly after and the grill was off. I tried turning it back on and the display would stay on for 5 - 10 seconds and it would shut off. I let it cool down, cleaned out the inside with a shop vac (it was not bad at all), power cycled it, and it still has the same problem. I have read that people with the ironwood are having this issue and it was caused from the software update. Is anyone else with the Pro 780 having this issue?
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
535
Reaction score
155
Points
43
Location
King County, WA State, US
Grill
PRO 780
I turned my grill on tonight to start cooking. Once I turned it on I had to wait several minutes as the software update was taking place. Once finished I turned the grill to 350, let it preheat, and put on my chicken. I went outside shortly after and the grill was off. I tried turning it back on and the display would stay on for 5 - 10 seconds and it would shut off. I let it cool down, cleaned out the inside with a shop vac (it was not bad at all), power cycled it, and it still has the same problem. I have read that people with the ironwood are having this issue and it was caused from the software update. Is anyone else with the Pro 780 having this issue?

If possible, try the following: Some folks have had success doing a Factory Reset of the WiFIRE Controller (assuming they can navigate to the right spot before it shuts off ...) ... Settings->About Grill-> push in the Dial button for up to 5 seconds until you see the Traeger logo appear on display ... release button ... tap Menu button to "wake up" ... then I would power cycle ...
 
OP
OP
C

CF422

New member
Joined
May 21, 2020
Messages
21
Reaction score
7
Points
3
Location
Washington State
Grill
Pro 780
If possible, try the following: Some folks have had success doing a Factory Reset of the WiFIRE Controller (assuming they can navigate to the right spot before it shuts off ...) ... Settings->About Grill-> push in the Dial button for up to 5 seconds until you see the Traeger logo appear on display ... release button ... tap Menu button to "wake up" ... then I would power cycle ...
I did see that suggestion. I was able to run through the reset and it did not work. Thanks for the suggestion
 

justinmorgan904

New member
Joined
May 22, 2020
Messages
3
Reaction score
0
Points
1
Location
California
Grill
Pro 780
I turned my grill on tonight to start cooking. Once I turned it on I had to wait several minutes as the software update was taking place. Once finished I turned the grill to 350, let it preheat, and put on my chicken. I went outside shortly after and the grill was off. I tried turning it back on and the display would stay on for 5 - 10 seconds and it would shut off. I let it cool down, cleaned out the inside with a shop vac (it was not bad at all), power cycled it, and it still has the same problem. I have read that people with the ironwood are having this issue and it was caused from the software update. Is anyone else with the Pro 780 having this issue?

Yes I discovered mine doing the same thing this morning. I turn it on and Traeger logo appears and then goes out.
 

Attachments

  • IMG_2658.MOV
    14.2 MB · Views: 83
OP
OP
C

CF422

New member
Joined
May 21, 2020
Messages
21
Reaction score
7
Points
3
Location
Washington State
Grill
Pro 780
I was able to get in touch with Traeger this morning and they are shipping out a new controller. I am going to check out the offline option suggested.
 

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
535
Reaction score
155
Points
43
Location
King County, WA State, US
Grill
PRO 780

dunawayfamily

Active member
Joined
Apr 23, 2020
Messages
535
Reaction score
155
Points
43
Location
King County, WA State, US
Grill
PRO 780
I just disconnected from my home WIFIRE and now my Traeger Pro 780 is good to go. Looks like Traeger has a software update glich which they pushed out yesterday. Thanks for the tip.

Not sure if this is a "recoverable" failure, or if Traeger Support is going to need to ship you out a replacement controller to get WiFIRE working again on your Home Wi-Fi Network ... you definitely want to reach out to find out what are your options :)
 

T Russo

New member
Joined
May 23, 2020
Messages
9
Reaction score
9
Points
3
Location
Arlington
Grill
Pro 575
I had the same issue with my Pro 757 series grill. I had no issues cooking on the evening of 5/22 but my attempts to fire up the grill on the morning of 5/23 failed.

Factory reset option didn’t correct the issue but disconnecting the controller from my WiFi did resolve the issue for me.

I’m waiting for a call back from Traeger Support to see what the resolution is for this. At least I can fire up my grill now over the Memorial Day weekend.
 
Top