Pellet Sensor

tony4402

New member
Joined
Nov 22, 2019
Messages
20
Reaction score
7
Points
3
Location
Bellingham, MA
Grill
Pro 575
Seeing lots of posts from folks excited about the Pellet Sensor and they have placed their order. Anyone receive and install yet? How's it working? My new grill and pellet sensor are on the way to me now. Install easy? App now accurately showing pellet levels?
 

EssWill

New member
Joined
Nov 28, 2019
Messages
9
Reaction score
7
Points
3
Location
Minneapolis, MN
Grill
Pro 575
I got one and installed it. But my grill isn't recognizing it as being there. I can see it has power as the sensor is emitting light, but my grill won't recognize it. I called support and they sent me some troubleshooting tips, and I will post again after I try those, and will let you know if it solved it.
 

CampWhatnot

Active member
Joined
Apr 1, 2019
Messages
380
Reaction score
94
Points
28
Location
Courtice, Ontario, Canada
Grill
Traeger Ironwood 650
I got one and installed it. But my grill isn't recognizing it as being there. I can see it has power as the sensor is emitting light, but my grill won't recognize it. I called support and they sent me some troubleshooting tips, and I will post again after I try those, and will let you know if it solved it.
Has your controller updated to the latest firmware? Perhaps the latest firmware is needed to work with the sensor?
 

EssWill

New member
Joined
Nov 28, 2019
Messages
9
Reaction score
7
Points
3
Location
Minneapolis, MN
Grill
Pro 575
Its now working. It wasn't the firmware -- I verified I had the latest -- although I have heard that lack of the latest firmware can cause issues. All I had to do was disconnect the sensor, power the grill on and then off again, reconnect the pallet sensor and then power grill back on again. It then recognized the sensor and allowed me to calibrate it. All good. My guess is that I may have installed the sensor the first time when the grill was powered on. I guess that can mess up the connection, so basically, I had to disconnect the sensor and start over.

I like the sensor, especially with a long cook/smoke, like today for my Thanksgiving turkey. It works well.
 

CampWhatnot

Active member
Joined
Apr 1, 2019
Messages
380
Reaction score
94
Points
28
Location
Courtice, Ontario, Canada
Grill
Traeger Ironwood 650
Its now working. It wasn't the firmware -- I verified I had the latest -- although I have heard that lack of the latest firmware can cause issues. All I had to do was disconnect the sensor, power the grill on and then off again, reconnect the pallet sensor and then power grill back on again. It then recognized the sensor and allowed me to calibrate it. All good. My guess is that I may have installed the sensor the first time when the grill was powered on. I guess that can mess up the connection, so basically, I had to disconnect the sensor and start over.

I like the sensor, especially with a long cook/smoke, like today for my Thanksgiving turkey. It works well.
Glad it worked out. I'm going to install mine over the wknd. Cheers
 

dblcrona

Active member
Joined
Dec 9, 2019
Messages
120
Reaction score
47
Points
28
Location
Manheim, PA
Grill
Pro 575
I just received my pellet sensor today. Took 5 minutes to install, calibrate and test. Works like a charm. Watched my app update real time as I poured pellets into the hopper. Makes me feel much better if I can figure out why I’m not getting audible alerts on my phone. I re-paired my grill so hopefully that will do the trick. I’ll find out shortly when I fire it up to make a pizza for dinner.
 
Top