Issues with D2 Freezing 780 Pro

swirth123

New member
Joined
May 4, 2019
Messages
4
Reaction score
1
Points
3
So we just received our Traeger 780 Pro on Thursday (2 days ago) Yesterday, when I was seasoning it I let it run for about 10 minutes. I came back and pressed the menu button and it took me to the menu, when I attempted to turn the dial....nothing happened, it wouldn't turn (it physically would turn, but it did nothing. It would also allow me to press in the dial to select "Timer" but I could not turn it to go lower in the menu. If I went into the "timer" setting, it would allow me to press in the dial to move from the hour to the minute selection...but it would not allow me to turn the dial to increase the hour/minutes.

So I restarted the grill, and everything worked as expected. Today we are actually cooking ribs for our 1st Traeger adventure. Everything worked as expected for the 1st 3 hours or so, then I came back and noticed the same issue occurring. I could press every button, but I could not turn the dial. Restarted it (because I needed to increase the temperature) and it worked. Now roughly 10 minutes into the temperature increase....same issue, turning the dial isn't responsive.

I tried to attach a 720p 5 second video, but apparently that's too large

What should I do here? Is this a serious issue with the grill?
 

Biffdotorg

Member
Joined
May 1, 2019
Messages
74
Reaction score
29
Points
18
Location
Dilworth, MN
Grill
Pro 780
We have not seen that happen one our one week old 780. But we have done most of our adjustments from the Wifire app. Have you noticed that when the panel was locked, so was WiFire?
 
OP
OP
S

swirth123

New member
Joined
May 4, 2019
Messages
4
Reaction score
1
Points
3
When it freezes, the wifire then says “grill offline” if you try to access it via the app
 

Biffdotorg

Member
Joined
May 1, 2019
Messages
74
Reaction score
29
Points
18
Location
Dilworth, MN
Grill
Pro 780
We did notice that our WiFire app would show offline quite often during my all day smoke on Friday. But I was able to go up to the grill and it was functioning properly. In fact, I was able to go to settings and scroll down to network status and see that it was losing connection.

So I must have had a different issue. I did roll up my heavily insulated garage door last night when cooking, and it never lost a connection. So you may have a need for a firmware update, or a warranty issue. That's a bummer Check the firmware threads here, as ours shipped with the latest firmware.

Good luck!
 
OP
OP
S

swirth123

New member
Joined
May 4, 2019
Messages
4
Reaction score
1
Points
3
Thanks friend, I’m going to look up how to perform an update now.
 

Biffdotorg

Member
Joined
May 1, 2019
Messages
74
Reaction score
29
Points
18
Location
Dilworth, MN
Grill
Pro 780
From what I was told, all you need to do was power it on in an area where it has solid WiFi connectivity. And leave it on as it should update on it's own. Only a customer support person can push an update out to it.

You can also confirm your firmware version as well. The latest for the Pro 780 should be as pictured below.

127


128


Good luck!
 
OP
OP
S

swirth123

New member
Joined
May 4, 2019
Messages
4
Reaction score
1
Points
3
Update: I contacted Traeger customer support and explained the issue. When I gave the girl my "UUID" she couldn't find it in her system. They are sending me a new "Controller" and that is supposed to resolve the problem.
 

Latest Discussions

Top