Slow to Heat Up

Timt465201

New member
Joined
Jun 15, 2020
Messages
3
Reaction score
1
Points
3
Location
Colorado
Grill
Ironwood 885
Hi All,
I purchased an Ironwood 885 yesterday and so far NOT IMPRESSED!
My grill takes more than an hour to preheat.... Is this normal (350F)
Main Temperature probe is 100 degrees off (yes you read correctly)

Does anyone else have this problem?
 

jp9724

Active member
Joined
Oct 23, 2019
Messages
250
Reaction score
78
Points
28
Location
Edmonton
Grill
Ironwood 885
was this the initial burn in? mine took a long time its first time. Now it averages 10 minutes now that its warm outside and with cleaned and pre-filled fire pot. And by pre-filled i mean with a small handful of pellets placed on the hot rod for new start up.
 
OP
OP
T

Timt465201

New member
Joined
Jun 15, 2020
Messages
3
Reaction score
1
Points
3
Location
Colorado
Grill
Ironwood 885
I found a couple of problems..... The grill was preassembled when I picked it up but it had never been used.
The temp probe was bent back and touching the sidewall of the grill.
I cleaned out the fire cup after a very long burn in.
Started it back up and slow cooked a slab of ribs all afternoon at about 225. Still seeing some variation in temp but it is manageable.
Thanks to all for your responses.... Yesterday I was ready to pack it up but today I am encouraged.
 

jp9724

Active member
Joined
Oct 23, 2019
Messages
250
Reaction score
78
Points
28
Location
Edmonton
Grill
Ironwood 885
You can also reach out to Traeger and they will likely send you a new temp probe!
 
OP
OP
T

Timt465201

New member
Joined
Jun 15, 2020
Messages
3
Reaction score
1
Points
3
Location
Colorado
Grill
Ironwood 885
update...... The temperature was still pretty far off (165 at the grill was actually 225). Went through customer support and they are sending me a new thermocouple.... hopefully with the new part I can quit burning ribs :)
 

Latest Discussions

Top