Help! Silverton is overheating / Auger won't stop

dmd7

New member
Joined
Dec 7, 2023
Messages
2
Reaction score
1
Points
1
Location
Indiana
Grill
Silverton
Help please! My Traeger Silverton is roughly 4 years old. Just recently when starting up -- I'll put it on Smoke setting until I see smoke and then I'll set it at a desired temperature (let's say 250). The Traeger will then produce a ton of smoke and then temperature will rise quickly to well beyond 250--- often going well above 400. I took out everything to see what the auger and fire pot looked like and each time I see the auger continuously feed pellets to the pot + there is a huge flame in the pot... so the thing is just cranking nonstop. It seems the auger won't stop/pause when the desired temp is reached.

I've replaced the controller and the RTD probe. The controller wires look matched up properly. I have no idea what to try next -- does anyone have any suggestions? I bought this used so nothing is under warranty. Hoping to fix myself before giving up and buying new.
 
Did you replace the controller and probe in an attempt to fix this issue, or were you fixing something else and then this started happening? Did you replace both parts with the same part numbers?
 
Did you replace the controller and probe in an attempt to fix this issue, or were you fixing something else and then this started happening? Did you replace both parts with the same part numbers?
Replaced the controller and probe in attempt to fix the issue. The replacement part descriptions said they were compatible with the Silverton model + they looked the same as what was already on the Traeger.... so I'm not worried I got the wrong parts. Any idea of why the auger won't stop once it reaches the desired temperature I've set it to?
 
My Traeger Silverton is roughly 4 years old. Just recently when starting up -- I'll put it on Smoke setting until I see smoke and then I'll set it at a desired temperature (let's say 250). The Traeger will then produce a ton of smoke and then temperature will rise quickly to well beyond 250--- often going well above 400. I took out everything to see what the auger and fire pot looked like and each time I see the auger continuously feed pellets to the pot + there is a huge flame in the pot... so the thing is just cranking nonstop. It seems the auger won't stop/pause when the desired temp is reached.

I've replaced the controller and the RTD probe. The controller wires look matched up properly. I have no idea what to try next -- does anyone have any suggestions? I bought this used so nothing is under warranty. Hoping to fix myself before giving up and buying new.
You need check for airflow blockages or auger jams; ensure proper alignment and functionality of the auger motor for consistent feeding.
 
Last edited by a moderator:
I’m having the exact same issue with my 4 year old Silverton too. I done the same repair procedures as AndrewSilver did to no avail. Please, anybody,help! This is getting very frustrating!
 
InkBird

Latest Discussions

Back
Top