New to Traeger

PriceMP5

Active member
Joined
May 26, 2019
Messages
161
Reaction score
100
Points
43
Location
Cleveland
Grill
Ironwood 650
Hey everyone,

New to Traeger and I'm off to a rough start, I assemble my new pro series 575 and It had to be returned because the heating element definitely wasn't working correctly. I have my new one assembled but I'm not sure it is working correctly. It doesn't seem to consistently producing smoke, I have it set at 230 and Its like the smoke is being produced in waves. I look outside at the smoker and Ill see a beautiful amount of smoke coming out of the stack and then 10 minutes later I peek outside and I see absolutely no smoke coming out. Is this normal? I expected a more consistent amount of smoke being produced during a cook. Worried this grill is defective in some way also.
 

SPD656

Member
Joined
May 6, 2019
Messages
74
Reaction score
41
Points
18
Grill
Timberline 850
Hey everyone,

New to Traeger and I'm off to a rough start, I assemble my new pro series 575 and It had to be returned because the heating element definitely wasn't working correctly. I have my new one assembled but I'm not sure it is working correctly. It doesn't seem to consistently producing smoke, I have it set at 230 and Its like the smoke is being produced in waves. I look outside at the smoker and Ill see a beautiful amount of smoke coming out of the stack and then 10 minutes later I peek outside and I see absolutely no smoke coming out. Is this normal? I expected a more consistent amount of smoke being produced during a cook. Worried this grill is defective in some way also.
I don’t have your specific model but I do know mine operates on and off in waves and you’ll hear the motor/fan push for a few then stop then it repeats the cycle especially at low and slow temps. If your curious if it’s working correctly crank it up to about 450-500 and see if it runs constantly...I bet it does. Watch some YouTube videos of traegers so you understand the noise and how it works. On low and slow temps it will sound like it’s not really doing anything sometimes.
 
OP
OP
P

PriceMP5

Active member
Joined
May 26, 2019
Messages
161
Reaction score
100
Points
43
Location
Cleveland
Grill
Ironwood 650
The only time my fan is starting and stopping is during the igniting. Once it is at Temp the fan is constantly running, currently doing a cook on some short ribs and each time I have checked on it the fan has been running whether there is a large smoke out put happening or hardly any at all. Also the internal temperature is running 30 degrees off of what my Meater temperature probe is reading which has me worried.
 

SPD656

Member
Joined
May 6, 2019
Messages
74
Reaction score
41
Points
18
Grill
Timberline 850
The only time my fan is starting and stopping is during the igniting. Once it is at Temp the fan is constantly running, currently doing a cook on some short ribs and each time I have checked on it the fan has been running whether there is a large smoke out put happening or hardly any at all. Also the internal temperature is running 30 degrees off of what my Meater temperature probe is reading which has me worried.
Shoot sorry man stand by for someone to reply with your model I can’t be of help on that.
 

primeone

Administrator
Staff member
Joined
Feb 12, 2019
Messages
899
Reaction score
379
Points
63
Location
Austin, TX
Grill
Ironwood 650
Welcome to the forum @PriceMP5 - I noticed my does the same thing (fan cycles on and off) if I'm cooking at a lower temps. At higher temps it's constant.
 
OP
OP
P

PriceMP5

Active member
Joined
May 26, 2019
Messages
161
Reaction score
100
Points
43
Location
Cleveland
Grill
Ironwood 650
I consider 230 degrees a low temperature in which the fan was running the entire time, my first 575 had a bad igniter so I am a little paranoid the grill has something wrong with it . Are the waves of smoke normal?
 

primeone

Administrator
Staff member
Joined
Feb 12, 2019
Messages
899
Reaction score
379
Points
63
Location
Austin, TX
Grill
Ironwood 650
I want to see it's anything less then 225. I'm planning a tri-tip or brisket on Tuesday and will try to test it and get some video to post.
 

ndfan6464

Member
Joined
May 18, 2019
Messages
77
Reaction score
15
Points
8
Location
Summerville, Sc
Grill
Pro 575 2019
Hey everyone,

New to Traeger and I'm off to a rough start, I assemble my new pro series 575 and It had to be returned because the heating element definitely wasn't working correctly. I have my new one assembled but I'm not sure it is working correctly. It doesn't seem to consistently producing smoke, I have it set at 230 and Its like the smoke is being produced in waves. I look outside at the smoker and Ill see a beautiful amount of smoke coming out of the stack and then 10 minutes later I peek outside and I see absolutely no smoke coming out. Is this normal? I expected a more consistent amount of smoke being produced during a cook. Worried this grill is defective in some way also.

Mine does the same thing. I'll have a good set of smoke then nothing and then a good set of smoke. In the user manual it states that the smoker will smoke in cycles. It spells out how many min between intervals but cant remember..few mins or so if I recall. But a true "blue smoke" is almost translucent. If you have heavy white smoke that will leave your food tasting acidic if thats how its cooking the wholetime, at least with traditional wood smoking. Heres a good article on the science of smoke.

Best website on the planet for learning about how to smoke and bbq anything and how tos for anything and everything related to smoking and bbq.

 

Latest Discussions

Top