Am I doing something wrong?

mbcordell

New member
Joined
Dec 29, 2020
Messages
2
Reaction score
0
Points
1
Location
Dallas, TX
Grill
Ranger
I just received a new Ranger portable grill, and followed the instructions in the manual, but it doesn't seem to be working. It turns on, and goes into idle mode, I pushed the top and right hand buttons to start the priming process, and the light shows that it's priming. I added pellets, but the auger is not turning, and the heating element does not seem to be heating up, and I don't feel any draft. I left it for about 5 minutes, and then turned it back off. Should the auger be moving before I add the pellets (it wasn't). Do I just need to let it run longer? Do I have to empty out the pellets and start over? Is there a way to empty them out easily, or do I have to pick it up and turn it upside down to dump them out? (Not gonna be an easy thing to do) I was really excited to get it started, but the instructions are minimal, and I can't find any good troubleshooting guides (including on the Traeger website) that covers what to do with this. Any guidance from more experienced users is so appreciated!
 

Jim G

Member
Joined
Dec 5, 2020
Messages
38
Reaction score
11
Points
8
Location
MN
Grill
Ironwood 885, Weber Genesis
Are you using this manual?
 

Attachments

  • ranger-grill-manual.pdf
    8.7 MB · Views: 4

Slimpicker

Moderator
Staff member
Joined
Aug 3, 2020
Messages
1,029
Reaction score
537
Points
113
Location
stl mo
Grill
Pro 575 Bronze
NOTE: Once you turn on your grill, it will enter Idle mode, and the display's dashed border will pulse. This indicates your grill is awaiting a command, and is not actively operating. The grill MUST be in Idle mode to prime the auger.

Make sure there are no foreign objects in the auger. With the grill in Idle mode, press and hold the UP and IGNITE buttons simultaneously. The display will flash "Pri" and the auger will begin priming. If you did NOT see your auger turning then don't add pellets and somehow start over!! Were you flashing "Pri"??? To get back to IDLE, Press and hold the UP and IGNITE buttons simultaneously to stop priming and return the grill to Idle mode. Maybe unplug and start over again. If your Auger doesn't start to turn in "Pri" mode then call Traeger Customer Support!!!

call (1-800-TRAEGER)​

6:00 am - 10:00 pm MST

Fill the hopper with your choice of Traeger Hardwood Pellets. The auger tube should take approximately 2 minutes to fill with pellets and begin dispensing into the Hot Pot. At this point the Hot Rod is NOT ON...

Continue priming until a small amount of pellets are in direct contact with the hot rod in the fire pot. Press and hold the UP and IGNITE buttons simultaneously to stop priming and return the grill to Idle mode.

You do not start burning pellets till you have pellets in the pot, all your grease tray and grill put back... then you set a temp and


Press the IGNITE button. Let the grill run at 450°F (250°C) for 30 minutes with the lid closed to complete the seasoning process.
 

Latest Discussions

Top